Impossible d’accéder a la page web de Zigbee2MQtt

Bonjour,
Je suis tout nouveau sur HA et je découvre tout l’environnement, je désire avec cette application gérer principalement mes points lumineux, dans un premier temps en tout cas !
L’installation est montée sur un « NUC ».

Mon problème

Je vient d’installer une clef « ConBee 2 » avec l’add-on « MQtt », la clef est bien reconnue voici la config de :
ZigBee2MQtt :

data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
mqtt:
  base_topic: zigbee2mqtt
serial:
  port: /dev/ttyACM0
advanced:
  log_level: warn
  pan_id: 6754
  channel: 11
  network_key:
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
frontend:
  port: 8099
experimental: {}
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: '-d -d'
  log: false

Lors du démarrage de l’add-on Zigbee2Mqtt, pas de problème apparent, par contre quand je veut accéder a sa page web j’ai un « 502: Bad Gateway ».
Donc dans le journal après qqe secondes :

[13:35:56] INFO: Handing over control to Zigbee2mqtt Core ...
> zigbee2mqtt@1.22.0 start
> node index.js
Zigbee2MQTT:error 2021-11-08 13:36:19: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2021-11-08 13:36:19: Failed to start zigbee
Zigbee2MQTT:error 2021-11-08 13:36:19: Check https://www.zigbee2mqtt.io/information/FAQ.html#help-zigbee2mqtt-fails-to-start for possible solutions
Zigbee2MQTT:error 2021-11-08 13:36:19: Exiting...
Zigbee2MQTT:error 2021-11-08 13:36:19: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:102:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:123:29)
    at Zigbee.start (/app/lib/zigbee.ts:58:27)
    at Controller.start (/app/lib/controller.ts:100:27)
    at start (/app/index.js:97:5)

Et la je bloque et grand besoin de vous :slight_smile:
Bav,

Ma configuration


[center]## System Health

version core-2021.11.1
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 5.10.75
arch x86_64
timezone Europe/Brussels
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 6.6
update_channel stable
supervisor_version supervisor-2021.10.8
docker_version 20.10.8
disk_total 228.5 GB
disk_used 5.2 GB
healthy true
supported true
board generic-x86-64
supervisor_api ok
version_api ok
installed_addons Samba share (9.5.1), MariaDB (2.4.0), AirSonos (3.1.1), File editor (5.3.3), NGINX Home Assistant SSL proxy (3.0.2), SSH & Web Terminal (9.0.1), Mosquitto broker (6.0.1), Node-RED (10.0.1), AdGuard Home (4.1.9), eWeLink Smart Home (1.2.3), Spotify Connect (0.9.1), Zigbee2mqtt (1.22.0-2)
Lovelace
dashboards 2
resources 0
views 2
mode storage
Spotify
api_endpoint_reachable ok
[/center]

Euh…

Ca ne sent pas très bon :wink:

En fait, c’est l’add-on qui n’est pas démarré.
Ou as tu trouvé les infos pour ça link=/tmp/ttyZ2M par exemple?
Typiquement une clé USB sur un NUC, ça devrait être un ttyACM0 ou ttyUSB0 ou… mais le ttyZ2M me semble curieux.

PS: J’i édité ton post pour mettre les infos entre </>. C’est (plus) lisible comme ça.

Bonjour golfvert,
Quand je parle de « pas de problème apparent » c’est que le démarrage se passe bien en tout cas dans la fenêtre de lancement et il affiche le lien vers la page web etc…
Par contre le « link=/tmp … » vient de l’installation de « Zigbee2MQtt » c’est la copie sans aucune modif de ma part dans cette section.
Comme tu l’as souligné je l’ai modifié en « ttyACM0 » mais sans résultat même réponse du log.
Et merci pour la clarté de mon msg :slight_smile:
Bat,

Oupssss je vient de voir ceci dans la doc de « Zegbee2mqtt »,

NOTE: You'll have to change both the master and the slave options according to your needs. The defaults values will make sure that socat listens on port 8485 and redirects its output to /dev/ttyZ2M. The zigbee2mqtt's serial port setting is NOT automatically set and has to be changed accordingly.

:slight_smile:

En suivant la doc j’ai ajouté un débug sur l’add-on et voici un peut plus de blabla,

[14:36:36] INFO: Zigbee Herdsman debug logging enabled
[14:36:37] INFO: Handing over control to Zigbee2mqtt Core ...
> zigbee2mqtt@1.22.0 start
> node index.js
2021-11-08T13:36:40.455Z zigbee-herdsman:adapter Failed to validate path: 'Error: spawn udevadm ENOENT'
2021-11-08T13:36:40.459Z zigbee-herdsman:controller:log Starting with options '{"network":{"networkKeyDistribute":false,"networkKey":[1,3,5,7,9,11,13,15,0,2,4,6,8,10,12,13],"panID":6754,"extendedPanID":[221,221,221,221,221,221,221,221],"channelList":[11]},"serialPort":{"path":"/dev/ttyACM0"},"databasePath":"/config/zigbee2mqtt/database.db","databaseBackupPath":"/config/zigbee2mqtt/database.db.backup","backupPath":"/config/zigbee2mqtt/coordinator_backup.json","adapter":{"disableLED":false,"concurrent":null,"delay":null}}'
2021-11-08T13:36:40.459Z zigbee-herdsman:adapter:zStack:znp:log Opening SerialPort with /dev/ttyACM0 and {"baudRate":115200,"rtscts":false,"autoOpen":false}
2021-11-08T13:36:40.465Z zigbee-herdsman:adapter:zStack:znp:log Serialport opened
2021-11-08T13:36:40.467Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2021-11-08T13:36:40.469Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
2021-11-08T13:36:40.721Z zigbee-herdsman:adapter:zStack:znp:log Writing CC2530/CC2531 skip bootloader payload
2021-11-08T13:36:40.722Z zigbee-herdsman:adapter:zStack:unpi:writer --> buffer [239]
2021-11-08T13:36:41.724Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2021-11-08T13:36:41.724Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
2021-11-08T13:36:41.974Z zigbee-herdsman:adapter:zStack:znp:log Skip bootloader for CC2652/CC1352
2021-11-08T13:36:42.427Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2021-11-08T13:36:42.428Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]

Si ca peut aider … :slight_smile: :thinking:

L’add-on ne trouve pas la clé…
La documentation Adapter settings | Zigbee2MQTT
propose de faire un dmesg après avoir branché la clé ou de laisser à null (et d’espérer).

Il manque à minima la ligne adapter: deconz dans la partie serial

https://forum1.hacf.fr/t/zigbee2mqtt-conbee2-installation/2066/9

Voila des réponses :
Le retour de dmesg pour la clef :

[    1.138050] usb 2-2: New USB device found, idVendor=1cf1, idProduct=0030, bcdDevice= 1.00
[    1.138058] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    1.138062] usb 2-2: Product: ConBee II
[    1.138066] usb 2-2: Manufacturer: dresden elektronik ingenieurtechnik GmbH
[    1.138070] usb 2-2: SerialNumber: DE2446734

Et pour le paramètre « serial port » pas possible de ne rien mettre il n’accepte pas de sauvegarder contrairement a ce qui est dans la doc, surement une erreur de syntaxe (j’ai essayé vide, null,[],{} ) je ne connait pas la syntaxe
Bat,

Bonsoir Pulpy,
Je vient d’ajouter « adapter : deconz » mais rien n’y fait, juste une question faut-il que l’add-on soit démarré en même temps que Zigbee2mqtt?
Je pense quand même avoir un soucis avec cette clef (toute neuve …) car dans « Phoscon »->passerelle/ rien n’apparaît :thinking: :thinking: :thinking:
Pareil dans le soft « Deconz » la cléf est vue mais impossible de la connecter !
Est-il possible de tester cette clef d’une autre façon, pour en être certain?
Bat,

Ta clé est vue (commande dmesg) …

c’est les logs qui donnent les infos interessantes

A ma connaissance, non

Je n’utilise pas l’add-on, ni cette clé là… Donc, pas sur du tout mais, je verrais bien:

data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
mqtt:
  base_topic: zigbee2mqtt
serial:
  port: /dev/ttyACM0
  adapter: null
advanced:
  log_level: warn
  pan_id: 6754
  channel: 11
  network_key:
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
frontend:
  port: 8099
experimental: {}

Donc, virer la partie socat et ajouter adapter: null
ca vient de là Adapter settings | Zigbee2MQTT

ça c’est sur que c’est pas bon…
Soit il n’y a pas de ligne (genre les ccXXXX), soit c’est deconz mais pas null

effectivement pas possible de sauvegarder !
Par contre voici le log avec port :‹ null › et adapter : deconz :

> zigbee2mqtt@1.22.0 start
> node index.js
2021-11-08T17:53:21.906Z zigbee-herdsman:adapter Failed to validate path: 'Error: spawn udevadm ENOENT'
2021-11-08T17:53:21.910Z zigbee-herdsman:deconz:driver Set delay to 0
CREATED DECONZ ADAPTER
2021-11-08T17:53:21.912Z zigbee-herdsman:controller:log Starting with options '{"network":{"networkKeyDistribute":false,"networkKey":[1,3,5,7,9,11,13,15,0,2,4,6,8,10,12,13],"panID":6754,"extendedPanID":[221,221,221,221,221,221,221,221],"channelList":[11]},"serialPort":{"path":"null","adapter":"deconz"},"databasePath":"/config/zigbee2mqtt/database.db","databaseBackupPath":"/config/zigbee2mqtt/database.db.backup","backupPath":"/config/zigbee2mqtt/coordinator_backup.json","adapter":{"disableLED":false,"concurrent":null,"delay":null}}'
2021-11-08T17:53:21.913Z zigbee-herdsman:deconz:driver Opening with null
Zigbee2MQTT:error 2021-11-08 18:53:21: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2021-11-08 18:53:21: Failed to start zigbee
Zigbee2MQTT:error 2021-11-08 18:53:21: Check https://www.zigbee2mqtt.io/information/FAQ.html#help-zigbee2mqtt-fails-to-start for possible solutions
Zigbee2MQTT:error 2021-11-08 18:53:21: Exiting...
Zigbee2MQTT:error 2021-11-08 18:53:22: Error: Error while opening serialport 'Error: Error: No such file or directory, cannot open null'
    at SerialPort.<anonymous> (/app/node_modules/zigbee-herdsman/src/adapter/deconz/driver/driver.ts:182:28)
    at SerialPort._error (/app/node_modules/zigbee-herdsman/node_modules/@serialport/stream/lib/index.js:198:14)
    at /app/node_modules/zigbee-herdsman/node_modules/@serialport/stream/lib/index.js:242:12
[18:53:22] INFO: Zigbee Herdsman debug logging enabled
[18:53:22] INFO: Handing over control to Zigbee2mqtt Core ...

mais toujours sans résultats !

Je ne fais que paraphraser la doc… Dans Adapter settings | Zigbee2MQTT c’est indiqué que c’est possible…

Tu es sur ACM0 ?

ça donne quoi ça ?

ls -l /dev/serial/by-id

L’important c’est la ligne du dessus

 # Optional: adapter type, not needed unless you are experiencing problems (default: shown below, options: zstack, deconz, ezsp)

voici

lrwxrwxrwx    1 root     root            13 Nov  8 14:57 usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2446734-if00 -> ../../ttyACM0

Donc tu mets

serial:
  port: /dev/ttyACM0
  adapter: deconz

Dans ta dernière trace tu as

serial:
  port: null
  adapter: deconz

oui juste je vient de remettre « /dev/ttyACM0 » et « deconz », rien n’y fait, mais il ne faut redémarrer que l’add-on, rien d’autre?

Oui dès que tu changes un truc, tu relances