Impossible d'installer HACS :(

Mon problème

bonjour
je tente en vain d’installer HACS… j’ai suivi ce tuto Comment installer HACS sur Home Assistant 2022 et étendre les possibilités de votre domotique
mais au moment d’aller dans intégration, +, je tape hacs mais il ne trouve rien du tout.

voici mon log :

We found a custom integration hacs which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant

Ma configuration


System Health

version core-2021.10.6
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 5.10.70
arch x86_64
timezone Europe/Paris
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 6.5
update_channel stable
supervisor_version supervisor-2021.10.0
docker_version 20.10.7
disk_total 30.8 GB
disk_used 2.0 GB
healthy true
supported true
board ova
supervisor_api ok
version_api ok
installed_addons Samba share (9.5.1), File editor (5.3.3)
Lovelace
dashboards 1
resources 0
views 1
mode storage
___

Bonjour

As-tu essayé de vider le cache de ton navigateur ?

ah merde c’était juste ca … merci !

Bonjour, même difficulté à installer HACS.
Ma configuration : server Qnap , HA core fonctionnel avec toutes les entités.
image
J’ai suivi le processus d’installation (Comment installer HACS sur Home Assistant 2022 et étendre les possibilités de votre domotique) mais avec les subtilités suivantes :
-Telechargement de Hacs sur GitHub : la décompression du zip montre entre autre un dossier ‹ translations › et non pas « .translations » comme indiqué. Est ce un pb ?
-Création du répertoire nommé « custom_components » sous config_dir la ou il y a configuration.yaml
-Copie du repertoire Hacs dézippé sous « custom_components » via le logiciel winSCP (et non pas file editor et wamp) est ce un pb ?
-vidage du cache et redémarrage de home assistant

  • Dans « HA/configuration/appareil s et services/intergration » je clique sur « +ajouter l’integration » et choisi Hacs.

Il vaut toujours mieux suivre la doc officielle… La procédure d’installation de HACS a pas mal évolué et les étapes que tu décris ne sont plus du tout celle que tu as faites.
Il faut aller là Prerequisites | HACS et suivre pas à pas ce qui doit être fait.

Merci pour votre retour.
Ce n’est pas facile de s’y retrouver avec tout ce que l’on trouve sur internet…
Ayant le niveau 0 sur le NAS et étant habitué à windows je bloque sur l’installation de hacs sur la version core de HA. indiqué dans le Prerequisite. Il est précisé :

  1. Open a terminal
    —>sur le NAS QNAP j’ouvre quoi en fait ? j’imagine que c’est une application équivalente à la fenêtre « invite de commande » de windows dans laquelle il faut coller les lignes de code de ‹ https://get.hacs.xyz ›, opération que je n’ai encore jamais fait (uniquement installé les applications dejà disponible dans une bibliothèque pre installée…)
    Pouvez vous m’indiquer un lien sur les basic de ce genre d’opération ?
  2. Change to the user that is running Home Assistant
    —>je n’ai pas vu ou dans le script il faut entrée le user
  3. Run the HACS download script

C’est pour ça que je parle toujours de la doc officielle. Les tutos plus ou moins exacts s’appuyant sur une version antédiluvienne, c’est la recette pour que ça foire.

Tu es sûr pour HA Core: Installation - Home Assistant ?
Pour installer comme ça, ça passe forcément par un accès en mode terminal sur le système ou est installé HA. Il faut donc faire la même chose que lors de l’install de HA.

pour la version core oui cf. ci-dessous
image
l’appli étant disponible en téléchargement, il m’a suffit de cliquer sur l’icone pour installer HA ! c’est à ma portée !!
J’ai accès aux fichiers du nas en ajout / modification via l’appli WinSCP, ce que j’ai fait pour créer le répertoire et transférer le repertoire Hacs… (mais qui ne fonctionne pas…)

OK. QNAP masque l’installation en venv par du clic. Un truc « compliqué » parait simple. Le problème c’est que tu vois la « complexité » de l’installation en mode venv pour le reste. N’ayant pas de QNAP, je n’ai pas forcément d’idée. Je suppose que dans le même genre que le clic pour HA, il doit y avoir un clic pour un démon SSH? Ca semblerait logique. Après, est-ce que ça existe, je ne sais pas.

Bjr,
J’ai progressé dans l’accés au code du NAS. J’ai installé putty, je me suis logge au NAS et lancé le code d’installation de Hacs.
J’ai le message suivant :
« ERROR: Could not find the directory for Home Assistant
Manually change the directory to the root of your Home Assistant configuration
With the user that is running Home Assistant
and run the script again »

Le directory de HA sur mon NAS est ‹ /share/cachedev1_data/.qpkg/HASS80/ ›
Question :

  • faut il que j’indique ce chemin quelque part dans le code d’installation de Hacs, si oui ou ? ( je ne suis pas très à l’aise avec ces lignes de code… et si c’est le cas faut il préciser davantage de chemin jusqu’à l’endroit ou se trouve le fichier configuration.yaml ?
    -sinon que faut il faire ?

Merci pour votre aide !