Intégrer une caméra

Mon problème

Bonjour, j’ai acheté une caméra Ezviz C6N (30€ chez Casto) et j’ai vu qu’elle était supporté par HA … il fût un temps. Actuellement le support est désactivé mais … il existe une intégration via HACS (GitHub - RenierM26/ha-ezviz: ezviz component for HASSIO, based on my fork of pyezviz) qui reprend le flambeau.
Il me semble avoir suivi la config à mettre dans configuration.yaml mais après je ne sais pas comment valider son intégration dans HA.
Si vous avez des pistes :wink:

J’irai poster sur le forum anglais sinon :slight_smile:

Ma configuration


System Health

version core-2021.2.3
installation_type Home Assistant OS
dev false
hassio true
docker true
virtualenv false
python_version 3.8.7
os_name Linux
os_version 5.4.83-v7
arch armv7l
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 4890
Installed Version 1.11.3
Stage running
Available Repositories 756
Installed Repositories 13
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Hass.io
host_os Home Assistant OS 5.11
update_channel stable
supervisor_version supervisor-2021.02.9
docker_version 19.03.13
disk_total 28.6 GB
disk_used 7.5 GB
healthy true
supported true
board rpi3
supervisor_api ok
version_api ok
installed_addons File editor (5.2.0), SSH & Web Terminal (8.0.1), deCONZ (6.7.0), Glances (0.11.0), Dropbox Sync (1.3.0), Samba share (9.3.0), Z-Wave JS to MQTT (0.4.1)
Lovelace
dashboards 1
resources 9
views 5
mode storage
___

Bon je me répond à moi-même.
J’ai pu intégrer cette caméra sauf la vidéo. La doc d’install sur le github de RenierM26 n’est pas commplet, il indique uniquement comment ajouter et configurer SON intégration via HACS.
… sauf qu’il manque une étapes : ajouter l’intégration ezviz dans Configuration > Intégrations de HA.

Donc il me reste la vidéo à trouver une solution pour la diffuser dans HA. Le flux rtsp via VLC fonctionne mais comment afficher dans une carte HA ? Quelle carte d’ailleur ?
A savoir que l’attribut rtsp est vide quand j’interroge la cam avec l’outil de développement, pour autant le flux rtsp://admin:mdp@ip_cam retourne bien la vidéo !!!

Une caméra sans video, c’est ballot :slight_smile:

Voilà comment j’intègre un flux rtsp:

camera:
  - platform: generic
    name: cam
    stream_source: rtsp://admin:mdp@ip_cam
    still_image_url: https://192.168.0.x/anonymous/snapshot/view
    authentication: basic
    verify_ssl: false

La partie après @IP doit être adaptée à la situation de chaque caméra.

Bonjour golfvert.,
J’ai encore besoin de vos lumières o combien précieuse sur le sujet de la cam .
Je dispose d’un portier konxs kw02c qui envoit un flux rtsp j’ai téléchargé sous ha l’addon ONVIF .
1 je tape l’adresse ip en laissant le port 5000 par défaut et je saisi mon login et password tout est ok
2 Il me demande le mécanisme de transport : quel doit être le choix entre tcp/udp /udp multicast /http
3 En rentrant sous vlc rtsp://192.168.1.xx:554/onvif1 l’image et le son apparaisse ( si je rajoute mon login et pwd c’est pareil tout est ok sous vlc )
4 J’ai copié :
camera:

  • platform: generic
    name: cam
    stream_source: rtsp://192.168.1.xx:554/onvif1
    authentication: basic
    verify_ssl: false
    5 sous lovelace j’ai ajouté une carte entité simple laquelle ou j’ai mis cam ( ps les reboot HA ont été réalisé )
    6 La caméra apparait en veille et quand je clique , une nouvelle fenêtre apparait avec une image noir et la roue qui tourne sans plus.
    Je ne vois pas ce qu’il me manque dans le YAML .
    Merci pour vos précieuses info.
    Arnold et toujours…

Déjà, il faudrait mettre le code dans les balises pour que l’on puisse mieux voir.
Je n’utilise pas l’intégration onvif. Donc, je ne sais pas pour 2.
Je comprends que le flux rstp décrit dans 3 marche si on donne user/pwd. C’est bien le cas?
Si oui, alors il faut les mettre dans la carte lovelace. Cf. mon exemple.
Là, tel que c’est écrit, il y a

mais pas les user/pwd… Donc, ça ne va pas le faire.

camera:

  • platform: generic
    name: Streaming Enabled
    still_image_url: http://192.168.1.23/jpg/image.jpg
    stream_source: rtsp://192.168.1.23:554/onvif1
    J’ai essayé également cela mais écran noir et cela tourne .
    En faite , je ne sais pas si j ai besoin de l application ONVIF ou pas , le seul truc que je sais est que mon
    adresse ip de mon portier est le 192.168.1.23:5000
    mais la lecture se fait par le port 554 avec deux résolutions possible soit onvif1 ou onvif2 .
    Il est probable qu’il faille rentrer le login et password quel serait la methode à faire selon ton post précedent?

Ne cherchez plus , j’ai effacé le contenu yaml correspondant puis j’ai réinstallé le plugin onvif
en prenant soit de rentrer l adresse ip de ma caméra j ai laissé le port 5000 par défaut puis ensuite
j’ai renseigné le login et password ( obligatoire pour ma cam ) .
Une fois découvert j’ai pris le soin d’activer les entités et ensuite sous lovelace j’ai utilisé une nouvelle carte nommée coup d’oeil en image en choisisant bien évidemment mon entité.
Si cela peut servir à qqn qui dispose d’une sonnette konxs kw02c je suis ravi d’apporter mon très modeste contribution. ( débutant sous home assistant )