Interrupteur Legrand NetAtmo - configuration des témoins lumineux

Bonjour,

J’ai intégré sans problème à mon Home Assistant via l’intégration ZHA un interrupteur double de la gamme Dooxie (Interrupteur double à câbler 2 circuits 250W pour installation connectée dooxie with Netatmo avec plaque blanche | Legrand)

Pas de problème pour faire fonctionner l’interrupteur par contre je n’arrive pas à faire fonctionner les deux leds temoins présente sur l’interrupteur. Visiblement ça se fait en configurant les « clusters » mais je sais pas comment faire ça sur HA.

J’ai trouvé ce tuto chez Jeedom mais je ne sais pas ou chercher sur HA pour trouver ces paramètres [TUTO] 💡 LEGRAND with Netatmo / Configuration avancée des équipements - Protocole domotique - Communauté Jeedom

Merci pour votre aide.

Mathieu.

1 « J'aime »

Salut,
oui, la configuration des leds témoin se fait en configurant les clusters mais avec ZHA, je ne l’ai jamais utilisé donc je ne saurai te répondre sur le sujet.
En revanche, en parlant de cet interrupteur, il n’était pas supporté avec zigbee2MQTT jusqu’à mon PR sur le github du projet donc si jamais l’envie te dit passer sous zigbee2MQTT, saches que l’interrupteur est supporté (aussi bien la gestion des allumages que le réglage des leds)

Salut @Carthage , merci pour les infos.

Je préfère rester sous ZHA, je vais donc voir pour contribuer et ajouter le support de mon interrupteur :slight_smile:

1 « J'aime »

@Carthage j’ai finalement basculé mon installation sous zigbee2MQTT mais visiblement le support ne semble pas total:

Aurais tu une idée d’où le problème pourrait venir ?

Merci :slight_smile:

@Math43 D’après ce que je vois, ça m’a l’air d’être ce device.
Si c’est bien celui-ci, il sera intégré lors de la prochaine mise à jour de zigbee2MQTT suite à mon PR.
Donc ne t’en fais pas, il sera pleinement supporté dès que la mise à jour sortira

Ce n’est pas tout à fait celui là mais son équivalent dans la gamme Dooxie (600082), je suppose que je vais devoir recopier ton code et juste changer l’ID.

Il existe un moyen de ne pas avoir a attendre la prochaine mise à jour ?

En théorie, le fonctionnement devrait être exactement le même.
Tu peux créer un fichier nommé ‹ 600082.js › dans le dossier zigbee2mqtt en mettant ce code à l’intérieur :

const fz = require('zigbee-herdsman-converters/converters/fromZigbee');
const tz = require('zigbee-herdsman-converters/converters/toZigbee');
const exposes = require('zigbee-herdsman-converters/lib/exposes');
const reporting = require('zigbee-herdsman-converters/lib/reporting');
const extend = require('zigbee-herdsman-converters/lib/extend');
const e = exposes.presets;
const ea = exposes.access;

const definition = {
    zigbeeModel: [' NLIS - Double light switch\u0000\u0000\u0000\u0000'],
    model: '600082',
    vendor: 'Legrand',
    description: 'Double wired switch with neutral',
    fromZigbee: [fz.on_off, fz.legrand_cluster_fc01],
    toZigbee: [tz.on_off, tz.legrand_settingAlwaysEnableLed, tz.legrand_settingEnableLedIfOn],
    exposes: [e.switch().withEndpoint('left'),
        e.switch().withEndpoint('right'),
        exposes.binary('permanent_led', ea.ALL, 'ON', 'OFF').withDescription('Enable or disable the permanent blue LED'),
        exposes.binary('led_when_on', ea.ALL, 'ON', 'OFF').withDescription('Enables the LED when the light is on')],
        meta: {multiEndpoint: true},
        configure: async (device, coordinatorEndpoint, logger) => {
            const endpointLeft = device.getEndpoint(1);
            await reporting.bind(endpointLeft, coordinatorEndpoint, ['genOnOff']);
            const endpointRight = device.getEndpoint(2);
            await reporting.bind(endpointRight, coordinatorEndpoint, ['genOnOff']);
        },
        endpoint: (device) => {
            return {left: 1, right: 2};
        },
};

module.exports = definition;

Ensuite, dans le fichier ‹ configuration.yaml › de zigbee2mqtt, tu ajoutes ceci dans la partie external_converters :

"external_converters":
  - 600082.js

En revanche, pour ce code, il se base sur les modifications que j’avais effectué. Pas sûr que tout soit reconnu.
Il faudra sûrement que tu adaptes le code.
Comme par exemple, la fonction fz.legrand_cluster_fc01, c’est le nouveau nom attribué à fz.legrand_device_mode. Pour les parties permanent_led et led_when_on, j’avais mis à jour le code car les fonctions ne retournées aucun état. Pour le reste, ça devrait fonctionner sans problème.

Merci pour les infos, c’est ce que j’avais commencé à faire mais je me suis retrouvé bloqué par l’absence de la fonction fz.legrand_cluster_fc01.

Tu sais si il existe un moyen de vérifier si tes modifications ont été ajouter à la release de Z2MQTT ?

Dans chaque release, tu as un récapitulatif des PR qui ont été effectués.
Les nouvelles releases sont effectués tous les 1er de chaque mois.
Mais pour information, les dernières modifications que j’ai faites seront disponible sur la release du 1er mars

Bonjour,

Finalement, les équipements de la gamme « Legrand by Netatmo » sont-ils compatible avec Home Assistant ?

Oui ils le sont. Par contre, toutes les fonctionnalités ne sont pas disponibles aussi rapidement qu’avec la centrale netatmo.

Que voulez vous dire par aussi rapidement ?
Il faut entrer dans le code ?

Ca dépend aussi de ton application zigbee.