Je n'arrive pas à voir mon SSD

Bonjour,

Mon problème

Après avoir préparer mon Raspi 4, j’ai tenté d’ajouter la même image de rasbian lite sur le SSD, mais une fois fini, mon SSD n’est plus visible, j’ai plus la partition root sur le PC (comme avec la carte SD), pour y mettre le SSH et le fichier de configuration Wifi…

Remarque

Dans le tuto Il n’y a pas tout a fait le même menu, juste après: « Demander le démarrage sur USB » dans raspi-config
J’ai testé d’ajouté le SSD sur le Raspb, mais le SSD clignote, mais rien, j’ai bien sûr pas de SSH

Le tutoriel d’origine

https://forum.hacf.fr/t/demarrer-son-raspberry-pi-4-sur-ssd/674

Ma configuration

Raspberry Pi4
SSD 120Go PNY CS900, carte Micro SD Sandisk
Adaptateur Sabrent USB 3.0 pour SSD (B011M8YACM)


Salut,

Branche un écran sur la PI, c’est un excellent moyen d’avoir des infos précises quand ça ne démarre pas.

Avez-vous bien mis à jour le bootloader du RPI4, sans ça il y a de fortes chances que le SSD ne puisse être reconnu.
Me souvient plus trop de quelle version minimum il faut disposer ! Mais google est ton amis.

Salut @Mourakami
De mémoire, c’est le pi3 qu’il faut mettre à jour. Sur le pi4 ça doit marcher de base

@Mourakami a raison de demander :+1:

De toute façon cela fait parti du tutoriel

Mettre a jour vers la dernière version du bootloader

1 « J'aime »

@Pulpy C’est bien le bootloader du RPi 4 qu’il faut mettre à jour. D’ailleurs, j’ai dû le faire il y a quelques temps pour pouvoir booter sur mon SSD

1 « J'aime »

Bonsoir.
J’ai rencontre le meme soucis. Il faut que tu prepares ton SSD.
Je me suis aidé d’un tuto d’Aminas TV sur Youtube pour debloquer la situation.

Bonjour à tous,

Oui bien-sûr, j’ai mis à jour le bootloader comme c’est décrit dans la procédure. J’e n’est pas eue de message d’erreur à ce niveau.
Mais par contre comme je vous le disais, dans la partie du tutoriel « Demander le démarrage sur USB », j’ai pas le même menu dans le raspi-config, sur la 1er page, je n’est pas le menu « boot option », mais je l’ai trouvé dans un autre menu, dans le « Advanced Options » il me semble.

Je pense plus à la préparation du SSD justement, merci Nyckel59, je vais essayer de trouver ce tuto d’AMINAS, car effectivement mon SSD n’est plus visible dans Windows une fois flasher contrairement au carte SD, je ne vois plus la partition root. Et pour relancer un flash dessus avec Balena… Je suis obligé de réinitialiser le disque dans le gestionnaire de disque de Windows.

En tout cas merci à tous, cela fait plaisir de ne pas être tout seul, c’est quand même pas si simple a installer tout sa ;).

Il y a eu une mise à jour de radpi-config, les menus sont différents mais les appellations devrait etre identiques.

1 « J'aime »

Bonsoir,

Mon problème principal viens de mon PC, j’ai mon SSD qui n’est plus visible, tout comme ma carte SD en faite. La carte SD est déclarer Hors connexion a cause d’une collision de signature. Même si je met pas le SSD en même temps.
J’était et je suis encore, complètement bloqué sur mon PC, impossible de reflasher la carte SD ou le SSD.
J’ai utilisé un autre PC et la nickel, cela fonctionne (sur le PC). J’ai tenté la réparation des disque dur en collision par ce site :https://vulgumtechus.com/Disque_dur_en_collision_de_signature , mais cela n’a rien changer, et tout les autres tuto que j’ai trouvé pour cela faisait la même chose ou pointait vers cette page.

Bon sa c’est pour mon PC.

Ensuite j’ai trouvé la chaine ArminasTV, Sur le coup sans le « r » je pensais que c’était une blague. Enfin j’ai suivi le tuto, et lorqu’il fait le test rpi-eeprom-config je n’est pas le boot-loader 0xf41, mais l’inverse, 0xf14, donc démarrage sur la carte SD.
J’ai suivi son explication ensuite, mais j’ai surement fait une bêtise, car cela a redémarrer le raspberry, et depuis il n’est plus accessible. que se soit avec la carte SD ou le SSD.

Donc faut que je recommence, mais c’est là que j’ai essayé de régler le problème de collision de mon PC sans résultat pour le moment.

[EDIT] Bon j’ai réessayé en flashant le tout à l’aide de mon PC portable, pas de souci pour les flash. Mais j’ai toujours pas de boot même en suivant le tuto de la chaine ArminasTV, ou celui de ce site., rien a faire.
J’ai toujours le BOOT_ORDER= 0xf14 au lieu de 0xf41

J’ai testé les flash avec Balena ou avec raspberry pi imager, bien plus long d’ailleurs, mais pareil, pas d’avancé.
J’ai pris l’image disque de rasbian lite comme conseillé.

Vous avez une idée?

Sur le fond, à partir du moment où ton bootloader est à jour ET que tu n’as pas de carte SD d’insérée, il doit booter sur ton SSD.

Au cas ou, vous auriez un boitier ou convertisseur SATA/USB3 qui fonctionne bien avec le raspb. Celui de la vidéo d’ArminasTV n’est plus dispo.

J’ai un convertisseur Sabrent USB 3.0, mais je vais essayer avec un autre plus ancien que j’ai, encore faut t’il que je le retrouve ;).

[EDIT] Bon cela venait bien de l’adaptateur USB Sabrent, j’ai retrouvé mon ancien et tout de suite cela a booté.

Bon je continue l’installation, merci a tous.

Et si vous avez un adaptateur ou boitier qui va bien, merci de me laisser un lien s’il vous plait.

2 « J'aime »

Tu peux tester les produits de la marque Ugreen. Ils fonctionnent très bien et sont de très bonnes factures :

1 « J'aime »

Sinon il y a la mise a jour du tuto sur l’installation sur raspberry via HAOS avec microSD et SSD recommandé par HA