Node-Red : Problème de lancement (Bad Gateway)

Mon problème

Je n’arrive plus à avoir accès à Node Red, j’obtiens une erreur 502 Bad Gateway.
J’ai lu le forum à la recherche de problème similaire mais je semble dans un autre cas :frowning:

Voici le message d’erreur que j’ai quand je tente de me loguer à Node-Red :

Welcome to Node-RED

1 Mar 10:07:19 - [info] Node-RED version: v2.2.2
1 Mar 10:07:19 - [info] Node.js version: v16.14.0
1 Mar 10:07:19 - [info] Linux 5.10.92-v8 arm64 LE
1 Mar 10:07:21 - [info] Loading palette nodes
2022/03/01 10:07:23 [error] 600#600: *1 connect() failed (111: Connection refused) while connecting to upstream, client: 172.30.32.2, server: a0d7b954-nodered, request: « GET / HTTP/1.1 », upstream: « http://127.0.0.1:46836/ », host: « xxxx.duckdns.org:8123 », referrer: « https://xxxx.duckdns.org:8123/a0d7b954_nodered »
1 Mar 10:07:29 - [info] Dashboard version 3.1.6 started at /endpoint/ui
1 Mar 10:07:31 - [info] Settings file : /etc/node-red/config.js
1 Mar 10:07:31 - [info] Context store : ‹ default › [module=memory]
1 Mar 10:07:31 - [info] User directory : /config/node-red/
1 Mar 10:07:31 - [warn] Projects disabled : editorTheme.projects.enabled=false
1 Mar 10:07:31 - [info] Flows file : /config/node-red/flows.json
1 Mar 10:07:31 - [info] Server now running at http://127.0.0.1:46836/
1 Mar 10:07:31 - [info] Starting flows
1 Mar 10:07:31 - [info] Connecting to freebox at https://192.168.1.254:443
[10:07:34] INFO: Starting Node-RED…

node $NODE_OPTIONS node_modules/node-red/red.js « –settings » « /etc/node-red/config.js »
1 Mar 10:07:56 - [info]

Ma configuration


[center]## System Health

version core-2022.2.6
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 5.10.92-v8
arch aarch64
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 5000
Installed Version 1.22.0
Stage running
Available Repositories 1073
Downloaded Repositories 17
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 7.4
update_channel stable
supervisor_version supervisor-2022.01.1
docker_version 20.10.9
disk_total 465.0 GB
disk_used 18.8 GB
healthy true
supported true
board rpi4-64
supervisor_api ok
version_api ok
installed_addons File editor (5.3.3), Samba share (9.5.1), Duck DNS (1.14.0), Grafana (7.4.1), InfluxDB (4.3.0), Node-RED (11.0.4), Mosquitto broker (6.0.1), SSH & Web Terminal (10.0.2)
Lovelace
dashboards 1
resources 14
views 19
mode storage
[/center]

salut, c’est suite à la maj de ce matin? tu y accedes par duckdns apparemment, et en ip local ca donne quoi? tu as rebooté HA ?

Oui j’ai rebooté HA et rien ne change :frowning:
Je n’ai fais aucune mise à jour ce matin

Si cela peut aider au dépannage voici mon fichier de configuration

certfile: fullchain.pem
credential_secret: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
http_node:
password: ‹  ›
username: ‹  ›
http_static:
password: ‹  ›
username: ‹  ›
init_commands: []
keyfile: privkey.pem
npm_packages: []
ssl: true
system_packages: []
theme: default
dark_mode: false
require_ssl: true
log_level: error

J’ai également cette erreur dans le log System :

22-03-01 11:18:49 WARNING (MainThread) [supervisor.addons.options] Option ‹ dark_mode › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:18:49 WARNING (MainThread) [supervisor.addons.options] Option ‹ require_ssl › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:18:49 WARNING (SyncWorker_0) [supervisor.addons.options] Option ‹ dark_mode › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:18:49 WARNING (SyncWorker_0) [supervisor.addons.options] Option ‹ require_ssl › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:18:49 INFO (SyncWorker_0) [supervisor.docker.addon] Starting Docker add-on Package node-red/aarch64 · GitHub with version 11.0.4
22-03-01 11:18:49 WARNING (MainThread) [supervisor.addons.options] Option ‹ dark_mode › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:18:49 WARNING (MainThread) [supervisor.addons.options] Option ‹ require_ssl › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:18:50 WARNING (MainThread) [supervisor.addons.options] Option ‹ dark_mode › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:18:50 WARNING (MainThread) [supervisor.addons.options] Option ‹ require_ssl › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:18:53 WARNING (MainThread) [supervisor.addons.options] Option ‹ dark_mode › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:18:53 WARNING (MainThread) [supervisor.addons.options] Option ‹ require_ssl › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:22:30 WARNING (MainThread) [supervisor.addons.options] Option ‹ dark_mode › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:22:30 WARNING (MainThread) [supervisor.addons.options] Option ‹ require_ssl › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:22:30 WARNING (MainThread) [supervisor.addons.options] Option ‹ dark_mode › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:22:30 WARNING (MainThread) [supervisor.addons.options] Option ‹ require_ssl › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:22:30 WARNING (MainThread) [supervisor.addons.options] Option ‹ dark_mode › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:22:30 WARNING (MainThread) [supervisor.addons.options] Option ‹ require_ssl › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:22:59 WARNING (MainThread) [supervisor.addons.options] Option ‹ dark_mode › does not exist in the schema for Node-RED (a0d7b954_nodered)
22-03-01 11:22:59 WARNING (MainThread) [supervisor.addons.options] Option ‹ require_ssl › does not exist in the schema for Node-RED (a0d7b954_nodered)

de mon coté : pour le dark mode :

certfile: fullchain.pem
credential_secret: ******************************
http_node:
  password: ''
  username: ''
http_static:
  password: ''
  username: ''
init_commands: []
keyfile: privkey.pem
npm_packages: []
ssl: false
system_packages:
  - ffmpeg
theme: dark
dark_mode: true
require_ssl: true

passe le ssl en false pour voir

et apres tout cela, si tu tapes http://ton_ip_local:1880 ca donne quoi?

J’essayerai ce soir sans le SSL car je suis à distance là et donc pas sur le réseau local.

Ton idée de passer hors SSL c’est quoi ? Tu penses que le certificat est pas bon ? Car si c’est cela, j’ai d’autres modules (Grafana par exemple) qui utilise aussi fullchain et privkey et ça fonctionne

En lisant ce post : Node red problem after updating packages 2022 - #5 by casperse - Node-RED - Home Assistant Community

J’ai mis safe_mode: true et j’ai à nouveau accès au Dashboard Node-Red

Mais j’ai toujours ce Warning dans les logs Supervisor

22-03-01 12:31:28 WARNING (MainThread) [supervisor.addons.options] Option 'require_ssl' does not exist in the schema for Node-RED (a0d7b954_nodered) 22-03-01 12:31:31 WARNING (MainThread) [supervisor.addons.options] Option 'require_ssl' does not exist in the schema for Node-RED (a0d7b954_nodered) 22-03-01 12:32:10 WARNING (MainThread) [supervisor.addons.options] Option 'require_ssl' does not exist in the schema for Node-RED (a0d7b954_nodered) 22-03-01 12:32:10 WARNING (MainThread) [supervisor.addons.options] Option 'require_ssl' does not exist in the schema for Node-RED (a0d7b954_nodered) 22-03-01 12:32:10 WARNING (MainThread) [supervisor.addons.options] Option 'require_ssl' does not exist in the schema for Node-RED (a0d7b954_nodered) 22-03-01 12:33:45 WARNING (MainThread) [supervisor.addons.options] Option 'require_ssl' does not exist in the schema for Node-RED (a0d7b954_nodered)

Et je ne peux pas retrouver le fonctionnement de mes flows car j’ai cette erreur dans Node-Red
image

J’ai trouvé le problème :muscle:

En fait c’est lié à la version du module Node-Red 11.0.4
image

En regardant le Git du projet, il y a un thread sur un problème avec le port Serial : Serial port crash on startup with 11.0.4 on ARM · Issue #1312 · hassio-addons/addon-node-red · GitHub
Ayant dans mes automations une lecture de mon Linky via USB mais sur l’interface Serial dans NodeRed. En débranchant simplement l’USB (et donc plus de lecture du Linky) immédiatement NodeRed refonctionne.

Il n’y a plus qu’à attendre une nouvelle version pour remettre en route ma lecture Linky via teleinfo

2 « J'aime »

Salut @crampes2 , j’avais pas fait gaffe, mais j’ai exactement le même problème.

Plus de remonté de ma clé USB connecté au linky.

As tu trouvé une solution ?

Oui c’est lié au module serial dans Node-Red qui fait planter tout NodeRed.
Ainsi :

  • soit tu débranches (par exemple le cable USB) le cable qui connecte ton équipement serial et Node-Red sera à nouveau disponible
  • soit tu modifies le paramètre de lancement en rajoutant le npm packages. Exemple :
        npm_packages:
          - node-red-node-serialport@0.15.0
1 « J'aime »

Ok. Je veux pas le débrancher, sinon mon linky ne remonte plus rien…
Après l’@ je mets comme toi ? Ou je dois mettre autre chose ?

Merci

Il te faut mettre exactement le texte comme je l’ai posté :slight_smile:

Ok merci. Je vais essayer !

Super déjà il redemarre. Une fois fait, il y a autre chose à faire pour que les flows refonctionnent ??

Je dois redéployer ou autre, ou non ?

Merci

Normalement il n’y a rien à faire de particulier, tous les Flow repartent sans action.

1 « J'aime »

C’est bon ça refonctionne :wink:

Bonjour,
je suis un débutant, avec ce même soucis. Pourrais tu me préciser dans quel fichier je dois ajouter npm_packages.
D'avance merci pour tes infos.

Sur Home Assistant, il faut aller :

  • Configuration > Add-ons
  • Choisir l’add-on Node-Red
  • Cliquer sur l’onglet tout en haut « Configuration »
  • Dans les options de NodeRed il faut rajouter la ligne npm_packages si elle n’y est pas.
npm_packages:
  - node-red-node-serialport@0.15.0
  • Revenir dans l’onglet « Info » et redémarrer l’add-on