Overclock Raspberry Pi 5 sous OS Home Assistant installé sur un ssd via port PCIe

Bonjour,

Je souhaiterais augmenter la fréquence du processeur de mon raspberry pi 5 qui démarre via le port PCIe avec un ssd (idéalement fréquence CPU et GPU pour améliorer le traitement des images).

J’ai beaucoup cherché comment faire, je suis tombé sur pas mal d’articles relatifs à la modification du fichier config.txt quand on démarre l’OS Raspberry Bookworm, par exemple sur une carte sd.
Mais je comprends aujourd’hui que les paramètres que j’adapte dans le config.txt en démarrant mon raspberry avec la carte sd ne sont pas applicables au démarrage avec le ssd sur lequel tourne Home Assistant.
Si j’ai bien compris, seules certaines adaptations peuvent être faites indépendamment d’un démarrage avec sd ou ssd, en accédant via le terminal à sudo raspi-config
Mais je ne sais pas adapter la fréquence du processeur à cet endroit.

Est-ce que quelqu’un dispose d’un Raspberry Pi 5, a adapté la fréquence de son processeur, et peut m’expliquer comment ?

J’ai lu qu’on pouvait passer de 2,4 GHz à 3GHz en restant en sécurité (relative, température à surveiller bien entendu). Mais en tout cas, les tests ne relèvent pas de bug à cette fréquence.

Merci à vous,

Ma configuration


[center]## System Information

version core-2024.5.2
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.12.2
os_name Linux
os_version 6.1.73-haos-raspi
arch aarch64
timezone Europe/Brussels
config_dir /config
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 4804
Installed Version 1.34.0
Stage running
Available Repositories 1393
Downloaded Repositories 37
Home Assistant Cloud
logged_in true
subscription_expiration 28 avril 2025 à 02:00
relayer_connected true
relayer_region eu-central-1
remote_enabled true
remote_connected true
alexa_enabled false
google_enabled true
remote_server eu-central-1-19.ui.nabu.casa
certificate_status ready
instance_id f0fd017040d14711b17f54352dde68e6
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 12.2
update_channel stable
supervisor_version supervisor-2024.04.4
agent_version 1.6.0
docker_version 25.0.5
disk_total 116.6 GB
disk_used 13.3 GB
healthy true
supported true
board rpi5-64
supervisor_api ok
version_api ok
installed_addons Terminal & SSH (9.13.0), File editor (5.8.0), Samba share (12.3.1), Home Assistant Google Drive Backup (0.112.1), Studio Code Server (5.15.0), Spotify Connect (0.13.0), OpenThread Border Router (2.6.0), Matter Server (5.6.0), Mosquitto broker (6.4.0), Frigate (0.13.2)
Dashboards
dashboards 2
resources 35
views 6
mode storage
Recorder
oldest_recorder_run 27 avril 2024 à 04:50
current_recorder_run 7 mai 2024 à 12:08
estimated_db_size 596.50 MiB
database_engine sqlite
database_version 3.44.2
Spotify
api_endpoint_reachable ok
[/center] Comment récupérer ma configuration : Dans votre HA, Menu latéral `Paramètres` > `Système` > `Corrections` puis les trois petits points en haut a droite > `Informations Système` puis une fois en bas `Copier` ___
1 « J'aime »

Bonjour,
je suis pas sur que sa soit la meilleur approche. Autant migrer sur un mini-pc plus puissant si tu trouve les performances du RPI5 limite.
Après comme tout overclocking, faut tester la stabilité , c’est pas juste copier des réglages trouver sur le net. Chaque processeur aura ces limites. Ca prends du temps a bien tester et je suis pas sur que sa soit le mieux sur un serveur domotique.

Bonjour WarC0zes,
Merci pour ton conseil :slight_smile:
Comme tu as sûrement vu mon autre post, j’avais essayé d’installer le coral usb mais il n’est pas compatible avec le raspi 5.
Vu que je viens de l’acheter et de commencer la domotique, je cherche une alternative.
Je suis intéressé par des retours d’expérience si certains ont tenté l’overclocking ?
Bonne journée,

Bonjour à tous,

Alors j’ai tout ré-installé et cela semble fonctionner.

Voici les étapes que j’ai suivies:

  1. Nouvelle installation Raspberry Pi 5 Bookworm full install via l’outil officiel de Raspberry sur ma carte sd 64Gb Scandisk
  2. Mettre à jour et activer port pcie : Comment configurer le boot PCIe NVMe sur Raspberry pi 5?
    Attention, je n’ai pas modifié l’ordre de démarrage pour pouvoir accéder à l’OS du Raspberry Pi dès que je mets la carte sd et que je redémarre (pratique pour accéder aux fichiers config, y compris ceux du ssd, sans devoir démonter le ssd à chaque fois)
  3. Installer l’utilitaire « Disques » : sudo apt install gnome-disk-utility
    En démarrant avec OS Raspberry Pi, dans Accessoires > Disques > Modifier les options de montage, Décocher « Réglage par défaut » pour que le disque soit monté au démarrage et pouvoir accéder au fichier config.txt du ssd.
  4. A ce niveau, le fichier config.txt du ssd était en lecture seule chez moi et je n’ai pas trouvé le moyen de l’éditer via « Disques ». Si vous savez comment faire, je suis intéressé.
    « Disques » m’a néanmoins permis de repérer le chemin d’accès au fichier config.txt du ssd vu qu’il est indiqué en haut de la fenêtre de ce fichier lorsqu’on l’ouvre, même en lecture seule.
  5. Programmer l’overclock via le terminal sous OS Raspberry Pi Bookworm:
    ° le fichier config du ssd est accessible via la commande « sudo nano /mnt/9320-80FB/config.txt » (déduction logique des commandes de base et du chemin d’accès constaté dans Disques) ;
    ° le fichier config.txt de la carte sd est simplement accessible via « sudo nano /boot/firmware/config.txt » , j’imagine parce que j’ai démarré l’OS avec et que je suis dessus…
  6. J’ai ensuite copié exactement les mêmes infos, et ce dans les 2 fichiers config de la carte sd et du ssd:
# Enable the PCIe external connector
dtparam=pciex1					
# Force Gen 3.0 speeds			
dtparam=pciex1_gen=3			
dtparam=nvme 					
# IMPORTANT: See note below
over_voltage_delta=50000
arm_freq=2800
force_turbo=1i

Ceci permet un overclock à 2,8GHz. J’ai lu sur plusieurs forums et Github que 3,0GHz pouvait aussi être stable mais c’est 2,8GHz qui revient le plus souvent sur un RasPi 5 sans rencontrer aucun problème. Maintenant, une machine n’est pas l’autre…

  1. Se connecter à distance sur Raspi 5 (pratique si comme moi vous n’avez que des portables ou l’écran TV trop grand et pas pratique): https://raspberry-lab.fr/Debuter-sur-Raspberry-Francais/Connexion-Bureau-a-distance-Raspberry-Francais/#google_vignette

L’adresse IP nécessaire à la config de l’accès distance a été repérée grâce à l’app « Fing » qui permet de scanner le réseau depuis un GSM. Attention, ce n’est pas la même IP que Home Assistant.

  1. Lorsque je redémarre mon Raspi 5 sans la carte sd (donc sur le ssd avec Home Assistant), la commande suivante me permet de vérifier la fréquence du processeur directement via le terminal de l’OS Home Assistant: « cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq »
    Cela semble avoir fonctionné:

Par contre, je ne sais pas si c’est possible de lire la fréquence en direct ?

Sur mon tableau de bord Home Assistant, j’ai ajouté l’entité qui me permet de suivre la température du CPU, vu l’overclock. Je dispose d’un ventilateur. J’ai constaté avoir pris environ 10°C avec cet overclock:

Et voilà le résultat du test que j’ai fait après overclock, je n’ai aucune différence en moyenne de temps d’accès, je ne sais pas si ça doit jouer…