Probleme ADB server

Bonjour,

J’ai plusieurs appareil android tv, dont la fire tv, j cherche à faire une config pour gérer cela apr Home assistant mais tout ce que je trouve comme tuto ont un point commun qui ne fonctione pas chez moi.

J’ai bien adb server installé et configuré avec toutes les ips rentré.

Sauf que lorsque je fait un script avec androidtv.adb_command home assistant me répond cela :

je cherche partout mais je ne trouve pas de solution claire. Si qq’un a une idée

Merci par avance

Salut,

Sans doute que le script en question apporterai un éclairage intéressant. Sans lui c’est bien moins facile pour trouver ce qui ne va pas.

La doc est là en tout cas : Android TV - Home Assistant

Ce n’est pas un prérequis vu qu’il y a le programme python inclus dans HA.

As-tu essayé avec le programme plutôt que le serveur ?

Sans parler du script, est-ce que le service est présent dans Outils de développement → Onglet SERVICES ?

Justement j’ai pas de script je l’ai effacé mais en gros ca ressemble à ce qu’il y a dans la doc… tu penses bien que je suis passé par la avant

Alors non je n’ai pas essayé et non dans SERVICES il n’y a pas androidtv.adb. Je me doute que le problème vint de lamais je ne sais pa comment y remédier.

Donc si c’est pas dispo dans les services, c’est que la déclaration de ta fire tv est pas faite ou pas bonne

media_player:
  - platform: androidtv
    device_class: firetv
    name: Android TV
    host: 192.168.0.111

dans media_player.yaml j’ai mis ca :

  • platform: androidtv
    name: Fire TV
    host: 192.168.0.177
    adb_server_ip: 127.0.0.1
    adb_server_port: 5037

c’est pas bon ?

Tu ne précise pas la classe… Donc c’est forcément moins bien. Et les deux dernières lignes ne servent à rien
De mémoire il y a aussi une validation de la clé de connexion je crois

Mais dans la doc ils parlent de la classe ? Car franchement ça me dit rien dans tout ce que j’ai lut.

Et la validation de la clé tu parle sur les appareils Android ? Si c’est le cas c’est fait

C’est dans les exemples…

Certes mais est-ce que c’est écrit qu’il faut le mettre ? si c’est le cas je suis passé à côté. Vu que c’est de l’anglais …

Et ça va résoudre mon problème d’erreur ?

je viens de le faire mais tjrs pas de service androidtv.adb_command

En principe, il n’y a pas plus à faire.
Par contre :

  • Tu as bien relancé le core ?
  • Ton fichier media_player.yaml est bien inclus dans le fichier configuration.yaml ?

Il faut repasser tous les points évidents en revue. Y compris ensuite :

  • C’est bien la bonne ip ?
  • Le mode développeur est bien activé sur la télé ?

C’est plus du process de recherche de solution.

Lorsqu’un élément est optionnel, on peut essayer de le renseigner.

Dans ce cas précis, le fait de ne pas le renseigner laisse le mode auto et donc @Pulpy te le signale en disant :

Donc la première étape de recherche de panne est d’éliminer les erreur de détection en forçant la valeurs.

C’est tout :wink:

alors oui je viens de vérifier et tout es bon … je comprend pas

ok merci pour cette précision je n’avait pas cette notion :grin: :grin:

1 « J'aime »

La vérif de la configuration est bonne ? et pas d’anomalie dans les logs non plus ?

Alors dans la validation de la configuration tous est ok mais dans les log j’ai plein d’erreurs j’en ai tjrs eu mais je n’ai jamais vraiment réussit a corrigé. Pas sur que ca est un rapport avec ca.

Tu veux le log ?

ça coute rien de jeter un oeil. Parce que là de toute façon… c’est mystérieux
A la limite tu peux aussi mettre ton configuration.yaml (sans les mots de passe)

Pour les log

Pour le config

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
switch: !include switchs.yaml
sensor: !include sensors.yaml
#camera: !include cameras.yaml
cover: !include covers.yaml
light: !include lights.yaml
media_player: !include media_players.yaml
fan: !include fans.yaml
notify: !include notificsations.yaml

# Example configuration.yaml entry
mobile_app:
discovery:

frontend:
  themes: !include_dir_merge_named themes
lovelace:
  resources:
    - url: /hacsfiles/lovelace-battery-entity-row/battery-entity-row.js
      type: module
    - url: https://cdn.jsdelivr.net/gh/Imbuzi/meteo-france-weather-card@1.1/dist/meteo-france-weather-card.js
      type: module

homeassistant:
  packages: !include_dir_named packages
  
api:
alexa:
  smart_home:

###########################################
#                   Boolean               #
###########################################  
input_boolean:
  shieldtv_chambre_ben:
    name: Eteindre Fire Tv
  shieldtv_salon:
    name: Lancer le ShieldTv salon
  mode1:
    name: Present
  mode2:
    name: Vacances
  soir:
    name: Soir
  volets_soir:
    name: Actif
  boombox:
    name: Mode Boombox
  systeme_son:
    name: Systeme son
  systeme_son_plus_fort:
    name: Systeme son plus fort
  systeme_son_moins_fort:
    name: Systeme son moins fort
  television:
    name: Power
###########################################
#               Shelly                    #
########################################### 
shelly:
  username: 
  password: 

###########################################
#                   RFLink                #
###########################################
rflink:
  port: /dev/serial/by-id/usb-Arduino__www.arduino.cc__0042_557323237303517061E1-if00
logger:
  default: error
  logs:
    rflink: debug
    homeassistant.components.rflink: debug
    
###########################################
#                   MQTT                #
###########################################
mqtt: 
  broker: 192.168.0.
  port: 
  username: 
  password: 
  discovery: true
  discovery_prefix: homeassistant
  
###########################################
#                   LAMPES                #
###########################################
yeelight:
  devices:
    192.168.0.:
      name: couloir2
    192.168.0.:
      name: couloir1
    192.168.0.:
      name: salle de bain
    192.168.0.:
      name: Halogene1
    192.168.0.:
      name: Halogene2

###########################################
#                   Purifieur             #
###########################################    
input_select:
  # Xiaomi Air Purifier 2S
  xiaomi_airpurifier_mode:
    name: Mode
    options:
      - Auto
      - Silent
      - Favorite
    icon: "mdi:animation-outline"

input_number:
  # Xiaomi Air Purifier 2S
  xiaomi_airpurifier_favorite_level:
    name: "Favorite level"
    initial: 0
    min: 0
    max: 14
    step: 1
    icon: "mdi:weather-windy"