Problème d'appairage VR Profalux et Zigbee

Mon problème

Bonjour,
2 de mes 4 VR type Profalux Zigbee sont identifiés comme Capteur alors que les 2 autres fonctionnent pleinement et sont bien reconnus comme VR.
Je suis complètement débutant.
L’intégration Zigbee se fait par le biais d’une Zigate USB.
J’ai fait un reset des télécommandes (5 fois sur R), un reset moteur (fil noir + fil marron pdt 5 secondes, puis fil noir + fil bleu, mouvement du volet, appuis sur bouton stop : la télécommande est appairée au volet), une ouverture du réseau (1 fois sur R puis touche Monter). HA voit la télécommande mais l’intègre comme un capteur.
Du coup, je ne peux pas les contrôler depuis HA.
J’ai refait les manipulation environ 20 fois…mais rien n’y fait.

Avez vous des idées?

Les VR ont été montés par KparK, n’ont pas de marque mais sont identiques aux Profalux. Ils datent de 2019 ou 2020 (me souvient plus exactement :sweat_smile:)

Merci d’avance
Ludo

Ma configuration

System Information

version core-2023.12.0
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.11.6
os_name Linux
os_version 6.1.63-haos
arch x86_64
timezone Europe/Paris
config_dir /config
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 5000
Installed Version 1.33.0
Stage running
Available Repositories 1349
Downloaded Repositories 1
HACS Data ok
Home Assistant Cloud
logged_in true
subscription_expiration 3 janvier 2024 à 01:00
relayer_connected true
relayer_region eu-central-1
remote_enabled true
remote_connected true
alexa_enabled true
google_enabled true
remote_server eu-central-1-3.ui.nabu.casa
certificate_status ready
instance_id 75ab5a6346e2498582a7e16f1fd00b97
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 11.2
update_channel stable
supervisor_version supervisor-2023.11.6
agent_version 1.6.0
docker_version 24.0.7
disk_total 228.5 GB
disk_used 5.5 GB
healthy true
supported true
board generic-x86-64
supervisor_api ok
version_api ok
installed_addons Duck DNS (1.15.0), Terminal & SSH (9.8.1)
Dashboards
dashboards 1
resources 0
mode auto-gen
Recorder
oldest_recorder_run 3 décembre 2023 à 08:43
current_recorder_run 6 décembre 2023 à 19:49
estimated_db_size 25.57 MiB
database_engine sqlite
database_version 3.41.2

Re-bonjour,

Je viens de penser à un truc :
Il y a quelques années, j’avais essayer d’appairer mes VR avec un Raspberry PI qui tournait sous Jeedom…sans succès.
Ne faudrait-il pas faire un reset de la mémoire flash et de l’EEPROM de la Zigate, pour tout remettre à plat et repartir sur une base saine?
Encore merci
Ludo

Bon,
J’ai effacer l’EEPROM de la zigate. Ca ne fonctionne toujours pas via ZHA.
Pensez vous que j’aurai plus d’options en passant par Zigbee2MQTT?
Ca coute rien d’essayer :stuck_out_tongue:

Salut alors avant de changer pour z2m tu peux essayer une autre manipulation.
Tu ouvre le réseau sur zha.
Tu appuis 5 fois sur R rapidement et le cinquième appuis tu le maintien 15 secondes
Tu attends les mouvements continue du volet et tu appuis sur le bouton stop.
Et normalement le volet doit être reconnu par zha

Hello Greg,
Merci pour l’info. Je testerai cela cette semaine. Je te tiens informé :blush:

Hello,
Bon, j’avais installé Zigbee2mqtt mais ça ne marche pas avec la Zigate. J’ai dons désinstallé et redemarré HA.
J’ai voulu réinstaller ZHA mais j’ai une erreur…


Une idée???

C’est sûrement par ce que zha et z2m entre en conflit. Il y a une procédure pour supprimer l’un pour pouvoir passer a l’autre. Je ne connais pas la procédure, mais tu devrais trouver l’info sur le forum.

1 « J'aime »

Bonjour,

@Greg_Wisniewski : Bon, j’ai testé le 4 fois sur R puis une cinquième fois pdt 15 secondes, le volet ne fait pas de mouvements… Rien à faire.
Entre temps j’ai installé correctement Zigbee2MQTT qui reconnait bien la Zigate.
Quand je lance l’appairage (R + haut), z2m reconnait bien la télécommande…mais QUE la télécommande et pas le volet. Je ne peux donc rien en faire.
Je m’arrache les cheveux :weary: :face_with_symbols_over_mouth:!!!
J’ai essayé plein de fois, réinitialisé le volet, retenté…mais toujours sans succès.
Quelqu’un a t il eu le même problème et a réussi à le résoudre?

Tu peux essayer le reset en 5.2

Je peux t’expliquer la procédure si tu n’y arrives pas :wink:

Tu peux avoir plusieurs versions de moteurs ( z1.2 et z3) et ce qui pose quelques problèmes.
La méthode 5.2 dégrade le moteur en z1.2 .

@Greg_Wisniewski : Alors, je n’ai pas le « cable de réglage »…
Et @14lfl : je pense déjà être en z1.2, dans la mesure ou les volets datent de 2019 ou 2020

@Greg_Wisniewski , si tu peux m’expliquer la procédure sans le cable de réglage, je veux bien :pray:

2020 toujours en z1.2

Quand tu fais reset du volet, c’est avec le fil noir?
Une fois reset fait, est ce que tu remets le noir vec le bleu ?

Couper l’alimentation mettre le fil noir sur la phase
Remettre l’alimentation
/ L’Equipement va faire :
• une 1ère série de
mouvements, attendre
• Une 2ème série de
mouvements, attendre
• Dès que l’Equipement
commence à refaire un
mouvement couper l’alimentation.
Remettre le fil noir sur le neutre
Activer le permis joint z2m
Remettre l’alimentation
Appuyer 5 fois sur R.
Attendre la fin des voyants
Pendant les mouvements de l’Equipement, faire un appui sur le bouton Stop

1 « J'aime »

@14lfl : j’ai essayé avec le fil noir non branché et avec le fil noir sur le bleu : même résultat.
@Greg_Wisniewski : je vais tester ta méthode. J’avais juste fait :

  • Fil noir sur le marron
  • après une première série de mouvements, débranchement
  • remis fil noir + bleu
  • après 2 mouvements, appuis sur stop pour réassocier la télécommande au volet
  • Dans z2m : permit to join
  • 1 appuis sur R + monter
    la télécommande entre dans z2m…mais que la télécommande.
    Est ce que dans ta méthode, je dois réassocier la télécommande au volet après avoir remis le fil noir sur le neutre?

Tu dois valider les fin de courses avant de tenter un appairage sinon il ne cherche aucun réseau

1 « J'aime »

Essaie déjà ce que te dit @14lfl il connaît bien ses volets et pour certains il faut valider les fin de course.
Pour la méthode que je t’ai explique Il faut bien supprimer la télécommande de z2m avant de commencer. Si tu suis la méthode a la lettre la télécommande ce réassocie tout seul quand tu fais 5 R et au mouvement du volet stop et en même temps le volet et la télécommande entre dans le réseau.
Fais la en dernier recours. J’avais le même problème que toi il n’y avait que la télécommande qui entrée et j’ai du faire cette méthode volet fin 2021 k par k

1 « J'aime »

@14lfl : ok, je valide les fins de courses après avoir réassocié la télécommande au volet, puis j’ouvre le reseau z2m. C’est bien cela?
@Greg_Wisniewski : oui, volets k par k…
J’essaye tout ça fin de semaine et vous tiens au courant.
Merci pour tout