Rajout commande manuellement

Bonjour à toutes et à tous,

Je dispose d’une ampoule osram smart+ zigbee qui remonte sur HA via zigbee2mqtt. j’ai bien la remonté de l’état et je peux la commande sans problème.
Par contre, je ne peux pas modifier l’intensité lumineuse (brightness) depuis HA alors qu’elle est bien présente et je peux la régler dans zigbee2mqtt.

est-ce qu’on peut rajouter une commande manuellement dans mqtt afin de la rajouter et si oui, comment faire? merci d’avance.

Salut.
Comment tu réalises ton changement de luminosité ? Si c’est visible dans zigbee2mqtt, çà devrait être fonctionnel directement depuis HA aussi. Si c’est pas le cas, c’est un bug.

j’arrive à le faire que dans z2m:


en agissant sur la barre brightness, je joue bien sur la luminosité mais rien dans MQTT:

si c’est un bug, où et comment puis-je le rectifier?

Tu peux utiliser la carte light

type: light
entity: light.led_cuisine
name: Led
icon: bha:led-strip
card_mod:
  class: top-level-card

en passant par outils dev/services, je peux piloter la luminosité.

donc par contre, pour une automatisation, il faut que je passe par la fonction « allumer lumière » et indiquer la luminosité:

est-ce qu’on peut mettre une formule dans la case luminosité?
je souhaiterais avoir : « valeur actuelle » - 40 (bien sûr, la sécurité pour ne pas avoir une valeur négative sera dans la condition)

Oui c’est le principe des automatisations, c’est de faire un peu ce qu’on veut… Tu pourrais même te baser sur le cours du dollars australien et la marée à Hawaï si tu avais envie :wink:

je serais plus sur le dollard canadien :grin:
je vais creuser sur l’automatisation, j’espère que la doc parle de cette méthode

plusieurs essai mais en vain :frowning_face:
afin de pouvoir mettre la luminosité en condition d’une automatisation, il faut que j’utilise une autre variable?

autre question qui est sur un autre type d’équipement mais qui reste en relation avec MQTT: comment je peux accéder aux informations de du broker MQTT afin de récupérer qu’une variable? (exemple: sur mes tête thermostatique, HA me mets plusieurs info sur une card alors qu’une seule m’interesse pour le moment)

Salut.

Sans un début d’indice sur ce que tu as déjà fait la réponse risque d’être vague… Si ton automatisation n’est pas bonne ça coince encore plus.
Passe par les outils de dev pour te faire la main sur la syntaxe :

Et par l’outils de création d’automatisation.

Il y a d’infinies possibilités de faire…

Que l’équipement soit mqtt, zigbee, Bluetooth ou autre ça ne change rien. Ils ont tous un état et éventuellement une série d’attributs en complément. Ça se manipule pareil, carte comprises. C’est la constitution de ta carte qui va déterminer quoi afficher

Je me permets un petit conseil. Commence simple et regarde la documentation… Il y a toutes les informations pour débuter sans se prendre la tête. Il va falloir abandonner certains réflexes jeedom, tu verras ha est plus logique😅

ce que j’essai de faire n’est pourtant pas compliqué en soit

c’est ce que je fais mais je trouve que la doc HA est vraiment mal foutu.

pour l’instant je fais que avec cet outils mails il me propose pas la luminosité dans les conditions et il ne me propose pas non plus quelque chose comme: nouvelle valeur = valeur existante - 10 (je n’ai rien trouvé dans la doc non plus, mais peut-être mal vu)

je te fais confiance sur ce point mais au moins, avec jeedom, en 1 minute c’était réglé et j’ai l’impression que leur doc est plus clair (quoique pas toujours quand même)

Même si avec la v4, la doc a pris un sacré coup de jeune chez Jeedom, tu verras qu’à la longue celle de HA est à des années lumières en avance :

  • 100% à jour
  • 100% complète
  • Exemples systématiques

Pour l’instant, tu es perdu car c’est nouveau…

C’est pour ça que je te dis d’oublier les habitudes jeedom, tu n’as pas (et n’aura jamais) un bouton pour changer la luminosité, c’est un attribut comme tous les autres…
Il faut donc passer par la méthode qui va bien…
Et puis comme tu ne dis toujours pas ce que tu veux faire ni nous montres ton code… pas moyen de te guider…
Pour ma part, j’ai juste cherché sur le forum et je tombe là dessus :

Je pense que ça fait largement plus que ce dont tu as besoin, mais ça va pouvoir te servir de base.

Oui, mais comparer un truc que tu connais avec un truc nouveau, ça n’a pas vraiment de sens … il faut pas plus de temps pour faire la manip sous HA une fois les concepts connus

je veux bien te croire mais pour l’instant, c’est clair comme du jus de chique dans une bouteille en bois

j’ai pas indiqué toute l’automation mais je l’ai indiqué le fonctionnement souhaité dans mon post n°5
pour résumer, la commande d’une ampoule en zigbee ce fait par 3 automations:
1 - appui simple: marche/arrêt de l’ampoule (ça, j’ai réussi)
2 - appui long: luminosité à 100% (ça aussi ça marche)
3 - double appui : réduire de 10% (c’est là que ça coince)
j’ai fait plusieurs essais en vain, je me rappelle même plus toutes les syntaxes testées

voici l’extraction du fichier automations.yaml de la partie en question

- id: '1634930770643'
  alias: Abajour salon réduction luminosité
  description: ''
  trigger:
  - platform: device
    domain: mqtt
    device_id: d553cd0485005c8f46733202496945a7
    type: action
    subtype: double
    discovery_id: 0x00124b0022689b3c action_double
  condition: []
  action:
  - data_template:
      brightness_pct: >
        {% if is_value{'brightness_tcp'} > 19 %} 100
        {% elif is_value{'brightness_tcp'} > 29 %} 20
        {% elif is_value{'brightness_tcp'} > 39 %} 30
        {% elif is_value{'brightness_tcp'} > 49 %} 40
        {% elif is_value{'brightness_tcp'} > 59 %} 50
        {% elif is_value{'brightness_tcp'} > 69 %} 60
        {% elif is_value{'brightness_tcp'} > 79 %} 70
        {% elif is_value{'brightness_tcp'} > 89 %} 80
        {% elif is_value{'brightness_tcp'} > 99 %} 90
        {% endif %}
    device_id: 164cc063c04cbd3fa45c4b6e6bc8d716
    entity_id: light.salon_abajour
    domain: light
  mode: single

pour l’instant, quand je vois le bordel que c’est juste pour varier la luminosité, l’intégration des mes arduino avec shield ethernet en MQTT semble pas gagner…
je sais pas si c’est parce que je suis hérité en ce moment (perso, pas par HA, du moins pas encore), mais je me suis vaguement dit ce matin que j’aurais peut-être du rester sur Jeedom… mais je m’avoue pas vaincu

Bon ben je crois que le souci est coté clavier non ? tcp ou pct

j’ai rectifié cette faute de frappe mais malheureusement c’est pas ça
par contre j’ai ces deux erreurs qui apparaissent:

Invalid config for [automation]: [data_template] is an invalid option for [automation]. Check: automation->data_template. (See /config/configuration.yaml, line 9).
13:52:35 – (ERREUR) config.py - message survenu pour la première fois à 13:08:22 et apparu 4 fois.
Template variable warning: 'dict object' has no attribute 'action' when rendering '{{ value_json.action }}'
13:19:54 – (ATTENTION) helpers/template.py - message survenu pour la première fois à 13:08:59 et apparu 4 fois.

alors que la ligne 9 de mon fichier configuration.yaml correspond à:

group: !include groups.yaml

Ca vient d’où ce is_value ?

Je ne le retrouve pas dans la documentation :

Tu devrais suivre l’exemple de @Pulpy et faire une recherche sur le forum du terme brightness_pct

Tu trouveras une automatisation de @Nardol avec un abaissement de luminosité de 10 pts… :innocent:

L’erreur est dans ton automation.yaml (donc sa ligne 9). Ton data template n’est pas bon dans sa syntaxe.

bon de retour après une petite pause et un grand mug de café.
merci @Pulpy et @Clemalex pour la solution que voici:

- id: 'id'
  alias: Abajour salon réduction luminosité
  description: ''
  trigger:
  - platform: device
    domain: mqtt
    device_id: <device_id>
    type: action
    subtype: double
    discovery_id: 0x00124b0022689b3c action_double
  condition: []
  action:
    service: light.turn_on
    data_template:
      entity_id: light.salon_abajour
      brightness_step_pct: -10
  mode: single

c’est pour ça que je trouve que la doc n’est vraiment pas clair, il y a des petits bouts partout donc pas simple voir impossible de s’y retrouver… (le fait que j’arrive de Jeedom simplifie encore moins la tâche)

1 « J'aime »

La documentation est très clair. :innocent: (quand on sait ce qu’on cherche…)

C’est exactement ça.

C’est la philosophie de HA et ses services, integrations, Add-on, python_script, etc qui ne me semble documenté nul part.

Je te conseille vivement de parcourir intensément les tutoriel du forum puis les demandes d’aide…

Il y a plein d’informations et tu comprendra au fur et à mesure (en croisant les données) de plus en plus la manière d’appréhender HA.

Bon courage

1 « J'aime »

quand tu connais la syntax ok mais quand tu es nouveau, la documentation devient pas très clair. on vient de le voir avec la luminosité de ma lampe. je sens que ça va être la même galère pour les têtes de chauffage connectées (j’ai remis les mécaniques pour garder le chauffage opérationnel). j’ai le retour de la température ambiante (ce qui est normal) mais en passant par les outils de dev comme m’a conseillé @Pulpy , cette information n’apparaît pas et pour chercher ce type d’information dans la doc… d’où que je trouve ça pas simple… je n’ose même pas pour l’instant penser à l’intégration des mes arduinos ethernet en MQTT…

je suppose que tu parles de jeedom pour la partie documenté nul part. il n’utilises pas ce principe d’intégration, add-on; juste des plugin que tu installes en fonction de tes besoins. la partie script serait dans un accès réservé aux développeurs.

Parce qu’il n’y a pas de question à se poser:
J’ai une sonde ‹ sonde_jardin › qui remonte humidité et température…
Quand tu vas dans les outils (ou dans les entités), tu filtres sur le nom :


Toutes les valeurs utilisables sont préfixées par ‹ sensor › (le type générique de jeedom en gros)
La colonne entités te donne les noms complets : type.nom_attribut (les [xx][yy][zz] de jeedom)
La colonne protocole permet de voir que c’est du 433Mhz et mais aussi que j’ai repris le nom de la sonde pour ajouter d’autres valeurs (des calculs)