Remplacer télérupteur par Sonoff mini r2

Bonjour,

comme j’en parlais déjà dans ma présentation.
Le premier petit projet que je me suis mis en tête est de remplacer un télérupteur fonctionnant avec 3 boutons poussoir par un sonoff mini.

J’ai choisi ce module car j’avais vu dans une discussion d’un forum jeedomm que quelqu’un l’avait justement fait :

Bon de mon côté je ne veux pas changer de système car Home assistant me plait de par son aspect opensource et communautaire :slight_smile:

J’ai déjà commencé mes tests et dans un premier temps j’ai d’abord suivi les infos concernant le câblage du Sonoff mini au niveau du tableau.

J’avais ce télérupteur :
telerupteur

j’ai donc démonté et récupéré la phase, le neutre, les 3 fils de retour BP et les 2 fils de retour lampe car j’ai deux ampoules.

J’ai ensuite suivi ce schéma de branchement :

En récupérant les 3 fils des BP reliés au disjoncteur sur la phase pour les brancher en S1

J’ai d’abord essayé la firmware tasmota et avec cette firmware j’ai trouvé une fonction SwitchMode que j’ai utilisé via la console de tasmota pour passer le module en SwitchMode 4

Avec cette configuration j’avais réussi à avoir un comportement normal pour 1 des 3 BP. Toujours le même.
Je pouvais gérer l’état du switch depuis ce BP et Home Assistant mais malgré la vérification des branchements au cas où je n’aurais pas bien fait les contacts je n’ai toujours eu qu’un seul BP qui été OK.

Plus par envie d’essayer autre chose j’ai flashé le Sonoff Mini avec ESPHome afin d’appréhender une autre solution.
J’ai réussi grâce à une petite pêche aux infos à faire fonctionner une carte pour allumer et éteindre le switch :

substitutions:
  device_name: sonoffmini
  device_ip: 192.168.x.x

esphome:
  name: ${device_name}
  platform: ESP8266
  board: esp01_1m

wifi:
  ssid: !secret wifi_ssid
  password: !secret wifi_password
  manual_ip:
    static_ip: ${device_ip}
    gateway: 192.168.0.1
    subnet: 255.255.255.0
  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "ESPHOME"
    password: "12345678"

logger:
  
api:
  reboot_timeout: 15min
  password: !secret api_password

ota:
  password: !secret ota_password

# the web_server & sensor components can be removed without affecting core functionaility.

web_server:
  port: 80

sensor:
  - platform: wifi_signal
    name: ${device_name} Wifi Signal Strength
    update_interval: 60s
  - platform: uptime
    name: ${device_name} Uptime
#######################################
# Device specific Config Begins Below #
#######################################

binary_sensor:
  # the 7 lines below define the reset button
  - platform: gpio
    pin: GPIO00
    id: reset
    internal: true  # hides reset switch from HomeAssistant
    filters:
      - invert:
      - delayed_off: 10ms
  # the 3 lines below toggle the main relay on press of reset button
    on_press:
      - light.toggle:
          id: light_id

  # the 13 lines below toggle the main relay on command
  - platform: gpio
    name: relay_toggle
    internal: true  # hides relay toggle from HomeAssistant
    pin: GPIO04
    id: gpio_light_id
    on_press:
      then:
        - light.toggle:
            id: light_id
    on_release:
      then:
        - light.toggle:
            id: light_id

  # the 2 lines below create a status entity in HomeAssistant.
  - platform: status
    name: ${device_name} Status

status_led:
  pin:
    number: GPIO13
    inverted: true

output:
  # the 3 lines below control the main relay
  - platform: gpio
    pin: GPIO12
    id: main_light_relay  
  # the 3 lines below control the Blue LED
  - platform: esp8266_pwm
    id: blue_led
    pin: GPIO13
    inverted: True

light:
  # the 4 lines below define the main relay as a light
  - platform: binary
    name: ${device_name}_light # you can enter a custom name to appear in HomeAsistant here.
    output: main_light_relay  
    id: light_id
  # the 4 lines below define the Blue LED light on Sonoff Mini, to expose in HomeAssistant remove line "internal: true"
  - platform: monochromatic
    name: ${device_name}_blueled
    output: blue_led
    internal: true # hides the Blue LED from Homeassistant

Mais sur ESPHome je ne trouve pas comment déjà coder l’info pour lui dire que j’ai des BP et non des interrupteurs classiques.

Ensuite cette histoire d’1 BP sur 3 qui fonctionne ne me semble pas lié au module en lui-même mais peut-être à une erreur de ma part dans le branchement ?
Comme les BP fonctionnaient bien avec le télérupteur je pense qu’ils sont bien branchés de base mais que je ne dois sûrement pas avoir compris le principe ^^

Désolé pour la longueur. J’ai voulu vous expliqué le plus en détail possible pour commencer à déblayer le terrain :grinning_face_with_smiling_eyes:

Bonne journée à vous.

Ma configuration


System Health

version core-2021.4.6
installation_type Home Assistant OS
dev false
hassio true
docker true
virtualenv false
python_version 3.8.7
os_name Linux
os_version 5.4.83-v8
arch aarch64
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 5000
Installed Version 1.12.1
Stage running
Available Repositories 776
Installed Repositories 10
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud undefined
Home Assistant Supervisor
host_os Home Assistant OS 5.13
update_channel stable
supervisor_version supervisor-2021.04.0
docker_version 19.03.15
disk_total 27.7 GB
disk_used 4.4 GB
healthy true
supported true
board rpi3-64
supervisor_api ok
version_api ok
installed_addons Samba share (9.3.1), Mosquitto broker (5.1.1), Terminal & SSH (9.1.0), File editor (5.3.0), Duck DNS (1.12.5), CEC Scanner (2.4), ESPHome (1.16.2)
Lovelace
dashboards 1
resources 3
views 6
mode storage
___

Salut,

Lequel de tes BP fonctionne? le premier?

A part une erreur de câblage, je ne vois pas pourquoi ça ne fonctionnerait pas.

Bonjour,

je ne saurais te dire électriquement.
Pour moi les BP sont en parallèle et arrivent tous au tableau.
J’ai 3 BP et bien 3 fils d’arrivée et de retour.

N’ayant pas de multimètre sous la main, la levé des restrictions ce weekend va être l’occasion de me faire aidé par un vrai électricien ^^

Je reviendrai donner les nouvelles :slight_smile:

Pour moi aussi ça me semble venir de la partie électrique. Mais mes connaissances sont maigres pour l’instant ^^

Je reviens aux nouvelles. :slight_smile:

Effectivement; m’ayant procuré un multimètre car l’électricien ne pouvait pas passer je me suis rendu compte que sur 3 BP deux étaient mal branchés :sweat_smile:

5mn plus tard tout est rentré dans l’ordre :grin:

Bonne journée à vous !

Je cherche à faire à peu près la même chose mais on est d’accord que cela ne fonctionne pas avec la version zigbee du module Sonoff (zbmini) qui ne gère pas le mode pulse ?

Bonjour demz,

désolé je passe régulièrement mais pas forcément connecté ^^

Effectivement avec les télérupteurs j’ai dû passer le sonoff en mode pulse.
Rien de compliqué après flash sur tasmota et avoir lu la doc qui va bien.

De ton côté en zigbee je ne serai pas le mieux placé pour t’orienter vers un module approprié :wink:

Je possède plusieurs zbmin et je te confirme qu’ils n’ont pas la fonction pulse contrairement aux modèle wifi qui eux ont cette fonction.
Pour palier, j’utilise une automatisation et cela fonctionne plutôt bien.

alias: 'Détecteur eclairage jardin: Mode Furtif 0,5s'
description: ''
trigger:
  - platform: device
    type: turned_on
    device_id: 046f3f7ccc666b59a51ca7c996c444a9
    entity_id: switch.detecteur_eclairage_jardin
    domain: switch
    for:
      hours: 0
      minutes: 0
      seconds: 0.5
      milliseconds: 0
condition: []
action:
  - type: turn_off
    device_id: 046f3f7ccc666b59a51ca7c996c444a9
    entity_id: switch.detecteur_eclairage_jardin
    domain: switch
mode: single
1 « J'aime »

Et du coup t’as remplacé ton télérupteur Rail DIN par le zbmini et les interrupteurs physiques des boutons poussoirs fonctionnent encore ?

non,
en fait, j’ai gardé le télérupteur et le zbmini fait office de bouton poussoir supplémentaire que j’actionne via une automatisation ou lorsque je veux allumer l’éclairage concerné avec mon phone.
Je garde ainsi les fonctions d’origine de mon installation électrique mais maintenant elle est domotisée.

Mais c’est top ça !
Tu as câblé comment du coup ?

Comme cela,


En fait le zbmin fait office de bouton poussoir connecté.
ATTENTION ! Ne pas oublier d’activer l’automatisation « mode furtif » sinon le télérupteur restera actif en permanence et il n’aimera pas ça du tout.
L’idéal serait d’avoir un mode pulse directement dans le firmware du zbmini comme dans le modèle wifi.

Mouais finalement je pense que je vais opter pour un vrai télérupteur ou un module qui supporte le pulse, je trouve ça plus propre au final.
Merci en tous cas !