SomfyProtect2MQTT

Bonjour,

J’utilise SomfyProtect2MQTT pour mon alarme myfox somfy.

Tout aller bien, jusqu’il y a 15 jours où cela ne fonctionne plus.

L’add-on ne veut plus démarrer. J’ai le message d’erreur « expected int » quand je veux démarrer l’addonJe voulais savoir si j’étais seul? :slight_smile:

Si oui, je recommencerai l’intégration avant de revenir avec mes questions…

D’avance, je vous remercie pour vos réponses.

Fred

Ma configuration


System Health

version core-2021.10.2
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 5.10.17-v8
arch aarch64
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 5000
Installed Version 1.15.2
Stage running
Available Repositories 880
Installed Repositories 4
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth failed to load: timeout
can_reach_cloud failed to load: timeout
Home Assistant Supervisor
host_os Home Assistant OS 6.4
update_channel stable
supervisor_version supervisor-2021.10.0
docker_version 20.10.7
disk_total 13.5 GB
disk_used 6.5 GB
healthy true
supported true
board rpi3-64
supervisor_api ok
version_api failed to load: timeout
installed_addons File editor (5.3.1), ESPHome (1.19.4), Samba share (9.5.1), Mosquitto broker (6.0.1), Duck DNS (1.12.5), Zigbee2mqtt (1.21.2-1), SomfyProtect2MQTT (0.1.5)
Lovelace
dashboards 1
resources 0
views 1
mode storage
___

Salut,

A priori, c’est ça qu’il faut partager ici… avec le reste des logs …

Merci d’avoir pris le temps de regarder Pulpy. Ci-dessous le fichier de configuration de l’add-on

somfy_protect:
  username: al@gmail.com
  password: 5XXXXX7
  sites:
    - Maison
homeassistant_config:
  code: set code or remove this line to disable code
  code_arm_required: false
  code_disarm_required: false
mqtt:
  host: 192.168.1.xxx
  port: 1883
  username: homeassistant
  password: aeshXXXXXXXXXXXXXXXXXXXXXXXX2oacu5
  client-id: somfy-protect
  topic_prefix: somfyProtect2mqtt
  ha_discover_prefix: homeassistant
delay_site: '10'
delay_device: '60'
debug: false

Et j’ai indiqué dans mon fichier de configuration yaml

somfy:
    client_id: yyyyy
    client_secret: xxxxx

OK et tu n’as pas de logs ?

Salut :wave:,

Merci de participer sur le forum :+1:

:information_source: Lorsque tu postes du code (flow, yaml, js, etc.), utilise les blocs codes :computer:

Pour cela, il te suffit de cliquer sur l’outil dédié et de coller ton code à l’endroit indiqué :

L’équipe HACF.

:hacf:

bonjour,
il te suffit de mettre false dans la ligne « code »

  homeassistant_config:
  code: false
  code_arm_required: false
  code_disarm_required: false

Juste au dessus :

https://forum1.hacf.fr/t/somfyprotect2mqtt/6688/5?u=clemalex

Un énorme Merci foXaCe, c’était ça!

Moi, j’effaçais cette ligne qui se remettait à chaque fois quand je sauvegarder.

Encore merci à toi et Pulpy qui avaient pris le temps de m’aider.

avec plaisir . le forum est la pour ca

Merci de reprendre ton message et de le formatter :+1:

Il ne pourras pas être marqué comme solution avant.