Tapo intégration caméras impossible

Bonjour,

J’ai deux caméras tapo C200 et une C500, qui fonctionnaient bien dans l’intégration tapo cameras ainsi que sur frigate et dans l’apllication smatphone tapo.
Un beau jour, les trois caméras sont devenues indisponibles dans l’intégration tapo, mais toujours fonctionnelles dans l’app smartphone ainsi que sur frigate.
J’ai installé une 4ème C200 via l’intégration tapo et elle est fonctionnelle ainsi que sur frigate.
Par contre à chaque fois que j’essaye de réinstaller les anciennes, j’ai ce message de l’intégration tapo :

Capture d'écran 2024-05-12 211651

Du coup, je me suis dit qu’il restait des bouts des anciennes caméras quelque part et ai désinstallé l’intégration, relancer complêtement et réinstaller la nouvelle C200.

Même résultat, la nouvelle fonctionne partout, les autres que dans frigate et l’app tapo.

Est ce que vous sauriez où trouver les traces d’installation des caméras ?

PS : toutes les tapos ont le même identifiant et password et fonctionnent sur vlc avec les url rtsp de frigate. Toutes les C200 ont le firmware 1.3.13 et la C500 1.1.3 avec les màj désactivées.

Merci.

Hello,

Quelques questions, certaines c’est juste pour êter sûr à 100%, si ça fonctionnait avant j’imagine que 1 et 2 doivent être ok:

  1. As-tu testé dans VLC si tu peux voir le flux de ta caméra en RTSP?

  2. Tu utilises bien le user:password créé dans l’application? Pas celui du compte Tapo.

  3. Je ne comprends pas pourquoi tu utilises l’intégration Tapo si tu as Frigate. Pourquoi ne pas utiliser l’intégration frigate et même utiliser go2rtc?

  4. Dans Frigate tu utilises RTSP ou Tapo?

tapo://my_tapo_cloud_password@camera_ip_locale
  1. Je pense que ton problème est le suivant: les caméras Tapo ne supporte que 2 flux vidéo en même temps au maximum! De TP Link Support: Partie 3 - Question 3
    Chaque caméra prend également en charge jusqu'à 2 flux vidéo simultanés. Vous pouvez utiliser jusqu'à 2 appareils pour afficher simultanément le flux en direct de la caméra à l'aide de l'application Tapo ou via RTSP.
    

Je te conseille fortement d’utiliser go2rtc sur Frigate puis l’intégration Frigate (via HACS) dans home assistant.

J’espère que ça t’aide.

Hello, merci pour la réponse.

  1. PS : toutes les tapos ont le même identifiant et password et fonctionnent sur vlc avec les url rtsp de frigate. Toutes les C200 ont le firmware 1.3.13 et la C500 1.1.3 avec les màj désactivées.

  2. même réponse

  3. J’utilise l’inégration tapo pour pouvoir les déplacer à distance, ce que ne permet apparemment pas frigate (avec les flèches de direction)

  4. Dans frigate avec les adresses rtsp => PS : toutes les tapos ont le même identifiant et password et fonctionnent sur vlc avec les url rtsp de frigate. Toutes les C200 ont le firmware 1.3.13 et la C500 1.1.3 avec les màj désactivées.

  5. c’est valable pour l’application smartphone tapo, avant j’avais toutes les caméras « presque en direct live sans lag » avec l’intégration tapo.

Au final, pourquoi je ne n’arrive pas à créer les caméras avec l’intégration tapo ? (pour mes anciennes caméras), c’est pourquoi je pense qu’il reste des traces quelque part.

Merci.

Chez moi, j’avais plusieurs connections avec les caméras qui empêchent la connection de-temps-en-temp (imprévisible). … deepstack/syno surveillance-center/camera card/tapo-app
Solution qui marche (pour moi) est d’installer go2rtc comme hub/centrale et de lier les autres connections vers ça
J’admis que c’est en place depuis +1an et je ne suis pas sûre si tapo-intégration devra fonctionner (mieux) maintenant

1 « J'aime »

Hello,

Donc j’ai laissé tombé l’intégration et suis passé par une carte frigate.Je récupère les 5 caméras :

Par contre, l’intérêt de l’intégration tapo était d’avoir des entités pour le PTZ de chaque caméra.

Ce qui ne fait pas parti de frigate.

Il y a un moyen de récupèrer ça de façon détournée ?

Merci

PTZ avec les Tapo et Frigate sans problème si t’utilises le « protocol Tapo » et non pas le RTSP:

Par contre je n’ai pas chercher à avoir le PTZ dans home assistant. Je pense que si tu l’as dans Frigate ça doit etre faisable, je n’ai pas creusé plus que ce post:

Merci pour la réponse, apparemment c’est un auto-tracking, pas pour manoeuvrer la caméra manuellement, si j’ai bien compris.

Avec l’intégration tapo, j’avais accés à ces possibilités.

Pour mon problème, je pense que le coeur du sujet doit être ça :

HomeAssistant - Tapo : contrôle des caméras
Composant personnalisé - Tapo : Contrôle des caméras - pour ajouter des caméras Tapo dans Home Assistant

Le micrologiciel 1.3.8 (ou build 230921) et les versions plus récentes peuvent empêcher l'intégration de fonctionner
Il y a eu des rapports d'utilisateurs sur les firmwares 1.3.8 et plus récents, ou sur certaines caméras, d'autres firmwares avec la build 230921 et plus récente d'intégration cessant de fonctionner. Si vous souhaitez continuer à utiliser cette intégration, jusqu'à ce que ce problème soit résolu, vous devrez soit :

Si votre caméra fonctionne toujours avec l'intégration : bloquez l'accès Internet de la caméra et arrêtez temporairement d'utiliser l'application téléphonique officielle si vous utilisez le firmware 1.3.8 (ou la version 230921 et supérieure).
Si votre caméra ne fonctionne plus avec l'intégration : utilisez un micrologiciel plus ancien que la version 1.3.8 (ou build 230921) et réinitialisez la caméra aux paramètres d'usine.

https://github.com/JurajNyiri/HomeAssistant-Tapo-Control

Vu que ça a arrêté de fonctionner du jour au lendemain sauf pour la nouvelle que j’ai installé.
Problème de màj de firmwares apparemment.

Merci.

Le PTZ fonctionne mais n’est pas intégré dans la carte Frigate.

Il faut donc faire des boutons qui appellent le service et c’est bon :slight_smile:

bonjour, merci pour la réponse.

Je ne connaissais pas, donc :

Capture d'écran 2024-05-16 075205

Et pas de bol, aucune caméra ne bouge

A moins qu’il y ai quelque chose à décalrer dans la config de frigate ?

Merci.

Edit : je reçois bien la commande via mqtt :

Capture d'écran 2024-05-16 080402

Tu as bien changé ta config dans Frigate pour utiliser tapo:// et non pas rtsp:// pour tes caméras?

Tu dois pouvoir utiliser le PTZ dans Frigate:

Par contre dans Frigate quand tu utilises le PTZ ça fait un petit mouvement de la caméra, avec le service depuis HA ça envoie la commande move right par exemple et ça bouge la caméra vers la droite jusqu’à ce qu’une commande STOP soit envoyée.

Hello,

J’ai bien modifié comme indiqué :

mqtt:
  enabled: true
  host: 192.168.1.3
  user: mqtt-user
  password: XXXXXXX/
  port: 1883

detectors:
  coral:
    type: edgetpu
    device: usb
    
cameras:
  salon:
    ffmpeg:
      inputs:
        - path: tapo:/XXXXX/@192.168.1.10
          roles:
            - record

Ca donne une erreur =>
Capture d'écran 2024-05-16 122422

et dans les logs :

2024-05-16 10:26:04.431834632  [2024-05-16 12:26:04] watchdog.salon                 ERROR   : Ffmpeg process crashed unexpectedly for salon.
2024-05-16 10:26:04.432494486  [2024-05-16 12:26:04] watchdog.salon                 ERROR   : The following ffmpeg logs include the last 100 lines prior to exit.
2024-05-16 10:26:04.432502685  [2024-05-16 12:26:04] ffmpeg.salon.detect            ERROR   : tapo://XXXXX@192.168.1.10: Protocol not found
2024-05-16 10:26:04.432505124  [2024-05-16 12:26:04] ffmpeg.salon.detect            ERROR   : Did you mean file:tapo://XXXXXX@192.168.1.10?
2024-05-16 10:26:04.465091342  [2024-05-16 12:26:04] frigate.video                  ERROR   : salon: Unable to read frames from ffmpeg process.
2024-05-16 10:26:04.465265949  [2024-05-16 12:26:04] frigate.video                  ERROR   : salon: ffmpeg process is not running. exiting capture thread...

J’ai changé le mdp cloud pour éviter les caractères spéciaux, pas mieux.
Essayé avec 192.168.1.10:554/stream1 : pareil.

A part le changement rtsp vers tapo, il y a autre chose à configurer dans le fichier frigate.yml ?

Merci.

Le onvif il me semble. Voici ma config:

go2rtc:
  webrtc:
    candidates:
    - ===frigate I{====:8555   # Frigate IP.
    - stun:8555
  streams:
    tapo_terrace:
    - tapo://====tapo cloud/app IP====@===tapo local ip===


cameras:
  tapo_terrace:
    enabled: true
    onvif:
      host: ===camera ip====
      port: 2020
      user: ====local user=====
      password: ===local password====
    ffmpeg:
      output_args:
        record: preset-record-generic-audio-copy
      inputs:
      - path: rtsp://127.0.0.1:8554/tapo_terrace
        input_args: preset-rtsp-restream
        roles:
        - record
        - detect

Je me rends compte que pour le control PTZ en fait juste l’ONVIF qui est nécessaire

Le tapo:// au lieu du rtsp:// m’a réglé un problème de stream qui se coupait tous les 2 jours

Re,

tout d’abord, un grand merci pour ta solution et ta patience, ça fonctionne.

Du coup, j’ai purgé un peu ton code :

mqtt:
  enabled: true
  host: 192.168.1.3
  user: mqtt-user
  password: XXXXXXXXXXXXXX
  port: 1883

detectors:
  coral:
    type: edgetpu
    device: usb

go2rtc:
  streams:
    salon:
      - tapo://XXXXX@192.168.1.10 # mdp cloud !!
    cuisine:
      - tapo://XXXXX@192.168.1.11
    chambre_avant:
      - tapo://XXXXX@192.168.1.33
    salle_a_manger:
      - tapo://XXXXX@192.168.1.12

cameras:
  salon:
    enabled: true
    onvif:
      host: 192.168.1.10
      port: 2020
      user: XXXXX         # user caméra
      password: XXXXX # mdp caméra
    ffmpeg:
      inputs:
        - path: rtsp://XXXXX:XXXXX@192.168.1.10:554/stream1
          roles:
            - record

Et le code pour le service fonctionnel, plus qu’à faire un petit flow sous nodered avec un reset temporisé

service: frigate.ptz
data:
  action: move
  argument: up
target:
  entity_id: camera.salon

La carte avec les 4 input_buttons :

Donc sous nodered ça donne

Capture d'écran 2024-05-16 193235

et le code du flow

[{"id":"c118cc491735a3b7","type":"server-state-changed","z":"53491665e37c8348","g":"6fe10b7e3d245c72","name":"Caméra salon left","server":"35ed60ee.1830b","version":5,"outputs":1,"exposeAsEntityConfig":"","entityId":"input_button.camera_salon_left","entityIdType":"exact","outputInitially":false,"stateType":"str","ifState":"","ifStateType":"str","ifStateOperator":"is","outputOnlyOnStateChange":true,"for":"0","forType":"num","forUnits":"minutes","ignorePrevStateNull":false,"ignorePrevStateUnknown":false,"ignorePrevStateUnavailable":false,"ignoreCurrentStateUnknown":false,"ignoreCurrentStateUnavailable":false,"outputProperties":[{"property":"payload","propertyType":"msg","value":"","valueType":"entityState"},{"property":"data","propertyType":"msg","value":"","valueType":"eventData"},{"property":"topic","propertyType":"msg","value":"","valueType":"triggerId"}],"x":1000,"y":1640,"wires":[["4d41e08eea14a285","535505103913d9fe"]]},{"id":"35ed60ee.1830b","type":"server","name":"Home Assistant","addon":true,"rejectUnauthorizedCerts":true,"ha_boolean":"","connectionDelay":false,"cacheJson":false,"heartbeat":false,"heartbeatInterval":"","statusSeparator":"","enableGlobalContextStore":false}]

Content que tu arrives à ce que tu voulais.

Par contre là tu configures go2rtc mais tu ne l’utilises pas.

Il faut demander le stream à go2rtc dans la config de la caméra:

à remplacer par:

   ffmpeg:
      inputs:
        - path: rtsp://127.0.0.1:8554/salon

Je viens d’essayer, les commandes PTZ sont beaucoup moins réactives.