Warning avec Nginx Proxy Manager

Mon problème

pourquoi ai je ces infos dans le journal supervisor

21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option 'domain' does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)
21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option 'certfile' does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)
21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option 'keyfile' does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)
21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option 'hsts' does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)
21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option 'cloudflare' does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)
21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option 'customize' does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)

Le tutoriel d’origine

Ma configuration


[center]## System Health

version core-2021.7.3
installation_type Home Assistant OS
dev false
hassio true
docker true
virtualenv false
python_version 3.9.5
os_name Linux
os_version 5.10.45
arch x86_64
timezone Europe/Zurich
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 4976
Installed Version 1.13.2
Stage running
Available Repositories 911
Installed Repositories 3
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 6.1
update_channel stable
supervisor_version supervisor-2021.06.8
docker_version 20.10.6
disk_total 58.4 GB
disk_used 4.4 GB
healthy true
supported true
board ova
supervisor_api ok
version_api ok
installed_addons File editor (5.3.2), Samba share (9.5.1), Mosquitto broker (6.0.1), Duck DNS (1.13.0), MariaDB (2.4.0), Nginx Proxy Manager (0.11.0), Z-Wave JS to MQTT (0.22.1), Zigbee2mqtt (1.20.0-1), Home Assistant Google Drive Backup (0.104.3), Check Home Assistant configuration (3.8.0), Terminal & SSH (9.1.3)
Lovelace
dashboards 1
resources 0
views 4
mode storage
/center] Comment récupérer ma configuration : Dans votre HA, Menu latéral `Configuration` > `Info` > bouton copier > `Pour Github` ![image|648x167, 75%](upload://1ietIxFU6nXP1GFrJTzwc2mh0j2.png) ___

Salut,

A vue de nez, on dirait un souci de syntaxe dans la configuration. Probablement juste en dessous de la partie Nginx, et qui contiendrait les lignes d’options :

  • domain
  • certfile
  • keyfile
  • hsts (il manque pas un o : hosts ?)
  • cloudflare
  • customize

le soucis c’est qu’il n’y aucune partie Nginx dans configuration.yaml comme tu peux le voir sur le tuto

c’est bien pour ça qu’il faut chercher les lignes en objet… Le tuto fait quand même modifier une partie en lien avec http:

je suis un noob, qu’entend tu par chercher les lignes en objet ?

mon configuration yaml :

http:
  ip_ban_enabled: false
  login_attempts_threshold: 3
  use_x_forwarded_for: true
  trusted_proxies:
    - 172.30.33.6
    - 172.18.0.1
    - 10.0.0.1
    - 172.16.0.1
    - 192.168.1.1

J’entends

  • parcourir la totalité du fichier configuration.yaml et des fichiers qui y sont inclus
  • regarder aussi dans la config nginx
    mariaDbConfig

Ce sont des mots clés particuliers (surtout cloudflare), ils ne devraient pas être présents en nombre

C’est pas le sujet ici, mais autant d’adresses de proxy et sur autant de scopes différents, ça me semble fort étonnant…

le seul endroit ou cloudflare est prestent c’est dans Nginx proxy manager modifié en yaml :

domain: (mon url)
certfile: fullchain.pem
keyfile: privkey.pem
hsts: max-age=31536000; includeSubDomains
cloudflare: false
customize:
  active: false
  default: nginx_proxy_default*.conf
  servers: nginx_proxy/*.conf

Donc c’est bien le bon endroit : (il y a toutes les lignes en question), n’ayant pas la source de cette modif (et pourquoi) il faut regarder si :

  • il n’y a pas un souci d’espace/indentation des lignes
  • que ces lignes sont bien des options possibles de la config nginx (ce qui ne semble pas le cas si on tiens compte des messages d’erreur au 1er degré)

Pour info, en cherchant rapidement, je ne trouve pas de config yaml en ce sens, mais du json classique

{
  "domain": "domain.duckdns.org",
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "hsts": "max-age=31536000; includeSubDomains",
  "cloudflare": false,
  "customize": {
    "active": false,
    "default": "nginx_proxy_default*.conf",
    "servers": "nginx_proxy/*.conf"
  }
}

hsts étant pour le HTTP Strict Transport Security

je dois m’absenter un moment je vois ça a mon retour

C’est pas le bon addon, le souci est dans NGINX Home Assistant SSL proxy

image

A priori, utile pour générer les certificats SSL ce que semble faire également Nginx Proxy Manager
Et comme il n’est pas mentionné dans le tuto, je ne sais pas s’il est indispensable (@Sylvain_G une idée ?)?
Si oui :
La mise en forme est-elle correcte (incluant les espaces en début de ligne ) ?
Que donne les logs de cette partie ?

Non il n’est pas nécessaire :wink:, NPM gère très bien les certificats.

@Malvu, je ne vois pas l’add-on que cite @Pulpy et qui renvoie des warning :

L’as-tu ? Tu n’aurais pas mis la configuration d’un autre add-on ? Refais le tutoriel en entier calmement :wink:

1 « J'aime »

:sweat_smile:

Egon: J’ai oublié de vous faire une recommandation essentielle.

Peter: Quoi ?

Egon: Ne jamais croiser les effluves.

Peter: Pourquoi ?

Egon: Ce serait mal !

@ SOS fantômes

1 « J'aime »
1 « J'aime »

Parfait ce petit extrait !
Du coup j’ai hâte de savoir la suite… Et la coïncidence avec le pseudo de @Malvu serai tellement improbable !

bon après de multiple essai, je me suis contrains a installer Nginx Proxy Manager ET Nginx Home Assistant SSL Proxy en parallèle.
cela a été la seule solution pour supprimer tout les message d’erreur et garder un accès externe.

Dans ce cas, il faut nous en dire plus sur LA/LES contrainte(S) qui t’amène à ce constat, parce que ça ne semble pas du tout indispensable d’avoir les 2. Et dans tous les cas, avec des fonctionnalités redondantes, c’est beaucoup plus lourd à maintenir. Que ça soit la solution ‹ facile ›, c’est fort possible, mais c’est aussi moins propre

Tout d’accord avec @Pulpy , c’est l’un ou l’autre.

Je reviens juste sur ton message d’origine qui indique qu’il ne trouve pas la configuration de ses options, donc refaire la configuration de NPM.
Et dernier point, tu vas avoir un conflit de gestion avec let’s encrypt avec ton addon Duck DNS et NPM. Il te faut désactiver la gestion Let’s Encrypt dans l’addon Duck DNS (si ce n’est pas déjà fait) et laisser NPM le gérer !

Tu devrais tout enlever et reprendre le tuto depuis zéro…

Je vais essayer d’être clair,

En premier lieu j’installe Nginx Proxy manager de ce fait je perd la connexion depuis l’extérieur en passant par Duckdns.
en modifiant la configuration avec l’option « modifier en tant que YAML » et en ajoutant ceci :

domain: votre domaine

certfile: nginxproxymanager/live/npm-1/fullchain.pem

keyfile: nginxproxymanager/live/npm-1/privkey.pem

hsts: max-age=31536000; includeSubDomains

cloudflare: false

customize:

active: false

default: nginx_proxy_default*.conf

servers: nginx_proxy/*.conf

L’accès est a nouveau possible MAIS avec des erreurs dans le journal supervisor :

`21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option ‹ domain › does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)

21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option ‹ certfile › does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)

21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option ‹ keyfile › does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)

21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option ‹ hsts › does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)

21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option ‹ cloudflare › does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)

21-07-16 16:43:18 WARNING (MainThread) [supervisor.addons.options] Option ‹ customize › does not exist in the schema for Nginx Proxy Manager (a0d7b954_nginxproxymanager)
`

Donc retour a la configuration par defaut de NPM et installation de NGINX Home Assistant SSL Proxy, en prenant soin de désactiver le port 443 dans la configuration.

Et là, tout fonctionne parfaitement (en tout les cas pour le moment) les messages d’erreur disparaisse et l’accès distant en SSL est actif.

On reprends depuis le début ?

Comment accèdes tu à HA sans Nginx ?

Tu as quelles redirections au niveau de ta box ?

Cette configuration ne correspond pas à cet add-on :upside_down_face:

Voici la documentation de l’add-on, tu ne trouveras pas ces lignes… :

1 « J'aime »