Zigbee2MQTT

Bonjour,

J’essaye de configurer Zigbee2 MQTT, celui-ci ne fonctionne pas ouverture de la page web (502 bad gateway), je souhaiterais flacher ma clef Zigbee Sonoff peut-être pour résoudre le problème mais je n’arrive pas à télécharger le logiciel « flash Programmer2 » impossibles de m’enregistrer sur le site texas instruments. Si une personne pourrais m’aidé s’il vous plaît.

Voici le résumer de mon journal de Zigbee2 MQTT et MQTT

> Zigbee2MQTT
> s6-rc: info: service s6rc-oneshot-runner: starting
> s6-rc: info: service s6rc-oneshot-runner successfully started
> s6-rc: info: service fix-attrs: starting
> s6-rc: info: service fix-attrs successfully started
> s6-rc: info: service legacy-cont-init: starting
> cont-init: info: running /etc/cont-init.d/socat.sh
> [22:21:05] INFO: Socat not enabled, marking service as down
> cont-init: info: /etc/cont-init.d/socat.sh exited 0
> cont-init: info: running /etc/cont-init.d/zigbee2mqtt.sh
> cont-init: info: /etc/cont-init.d/zigbee2mqtt.sh exited 0
> s6-rc: info: service legacy-cont-init successfully started
> s6-rc: info: service legacy-services: starting
> services-up: info: copying legacy longrun socat (no readiness notification)
> services-up: info: copying legacy longrun zigbee2mqtt (no readiness notification)
> [22:21:06] INFO: Handing over control to Zigbee2MQTT Core ...
> > zigbee2mqtt@1.26.0 start
> > node index.js
> Zigbee2MQTT:info  2022-07-03 22:21:10: Logging to console and directory: '/config/zigbee2mqtt/log/2022-07-03.22-21-10' filename: log.txt
> Zigbee2MQTT:info  2022-07-03 22:21:10: Starting Zigbee2MQTT version 1.26.0 (commit #unknown)
> Zigbee2MQTT:info  2022-07-03 22:21:10: Starting zigbee-herdsman (0.14.40)
> Zigbee2MQTT:info  2022-07-03 22:21:11: zigbee-herdsman started (resumed)
> Zigbee2MQTT:info  2022-07-03 22:21:11: Coordinator firmware version: '{"meta":{"maintrel":1,"majorrel":2,"minorrel":7,"product":1,"revision":20210708,"transportrev":2},"type":"zStack3x0"}'
> Zigbee2MQTT:info  2022-07-03 22:21:11: Currently 0 devices are joined:
> Zigbee2MQTT:info  2022-07-03 22:21:11: Zigbee: disabling joining new devices.
> Zigbee2MQTT:info  2022-07-03 22:21:11: Connecting to MQTT server at mqtt://core-mosquitto
> Zigbee2MQTT:error 2022-07-03 22:21:11: MQTT failed to connect: Connection refused: Not authorized
> Zigbee2MQTT:error 2022-07-03 22:21:11: Exiting...
> Zigbee2MQTT:info  2022-07-03 22:21:11: Stopping zigbee-herdsman...



> # Mosquitto broker
> 
> error: received null username or password for unpwd check 1656879654: Client <unknown> disconnected, not authorised. 1656879655: New connection from 172.30.33.1:58032 on port 1883. error: received null username or password for unpwd check 1656879655: Client <unknown> disconnected, not authorised. 1656879656: New connection from 172.30.33.1:58038 on port 1883. error: received null username or password for unpwd check 1656879656: Client <unknown> disconnected, not authorised. 1656879657: New connection from 172.30.33.1:56774 on port 1883. error: received null username or password for unpwd check 1656879657: Client <unknown> disconnected, not authorised. 1656879658: New connection from 172.30.33.1:56786 on port 1883. error: received null username or password for unpwd check 1656879658: Client <unknown> disconnected, not authorised. 1656879659: New connection from 172.30.33.1:56788 on port 1883. error: received null username or password for unpwd check 1656879659: Client <unknown> disconnected, not authorised. 1656879660: New connection from 172.30.33.1:56790 on port 1883. error: received null username or password for unpwd check 1656879660: Client <unknown>

Salut,

Le souci c’est pas la clé mais la config MQTT ip/port/user/password à vérifier coté MQTT et coté Z2M

2 « J'aime »

Ah bon je vais regardé à nouveaux merci de m’avoir repondu si rapidement :grinning:

Salut,
Essai cette manip @pulpy et @alexhass m’avaient conseillés ceci et ça venait bien du user et password.
[https://forum.hacf.fr/t/unable-to-connect-to-the-mqtt-broker-connection-refused-not-authorised/11772/5]

1 « J'aime »

Je ne sais pas si avec cela on peut voir l’erreur?

Z2M

> data_path: /config/zigbee2mqtt
> socat:
>   enabled: false
>   master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
>   slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
>   options: '-d -d'
>   log: false
> mqtt:
>   username: mqtt
>   password: toto22
> serial:
>   port: >-
>     /dev/serial/by-id/usb-ITead_Sonoff_Zigbee_3.0_USB_Dongle_Plus_a0512cde8a12ec11a4d920c7bd930c07-if00-port0

MQTT

logins:
  - username: mqtt
    password: toto22
require_certificate: false
certfile: fullchain.pem
keyfile: privkey.pem
customize:
  active: false
  folder: mosquitto

Je vais essayé c’est gentil merci

Dans la config z2m l’adresse du server à specifier peu être

server: mqtt://192.168.x.x:1883
user: xxxx
password: xxxxxxxxx
2 « J'aime »

Je ne sais pas ou rentrer ses information dans le fichier yaml de z2m

Tu peux faire tout cela dans l’éditeur visuel d’ HA
Dans paramètres, modules complémentaires, zigbee2mqtt et configuration

Bien merci j’ai ajouté le server dans le fichier mais ne fonctionne pas. Désolé pour mon manque de connaissance je débute avec HA

data_path: /config/zigbee2mqtt
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: '-d -d'
  log: false
mqtt:
  server: mqtt://192.168.1.73:1883
  username: mqtt
  password: toto22
serial:
  port: >-
    /dev/serial/by-id/usb-ITead_Sonoff_Zigbee_3.0_USB_Dongle_Plus_a0512cde8a12ec11a4d920c7bd930c07-if00-port0

Merci, j’ai déja suivi cette aide mais ca ne fonctionne pas il y a quelque chose que je dois faire mal :thinking:

Un reboot d’ HA pour prendre en compte les modifs

Rien à faire même aprés le redémarrage je ne comprend pas mon erreur

Zigbee2MQTT:error 2022-07-03 23:14:20: MQTT failed to connect: Connection refused: Not authorized

Essai de refaire reconfigure sur la tuile mosquitto broker dans paramètres, appareils et services

J’ai supprimé la tuile et je ne sais plus quoi remplir sous Broker.

Tu peux aussi confirmer avec MQTT explorer que les infos sont les bonnes coté MQTT

Merci un logiciel bien sympa pour la configuration, je vais voir le fonctionnement

Sa ne m’avance pas je dois comprendre quoi remplir pas simple HA quand même

Avec mqtt explorer tu le lance tu renseigne ton server mqtt, ton user et password et voir si tu peux t’y connecter