Integration clim airton

Hello Jean-Marc,
J’ai essayé de commencer à modifier le fichier core.config_entries pour ajouter les entités manquantes. Je dois manifestement faire un truc de travers car ca m’a flingué tout mon HA et je n’avais plus aucune entités. Je vous le dis vive les backups avant de toucher à des trucs sensibles sinon la je n’avais que mes yeux pour pleurer. Bref Ca se termine bien heureusement j’ai rollback. Du coup j’aurais voulu savoir où je devais rajouter les entités manquantes:


Est-ce entre la } et le ] la ou il y a ma flèche bleu? Et du coup si je fais comme ca par exemple pour une entité, est-ce correct?:
{
« entry_id »: « ------------------------------------------------ »,
« version »: 2,
« minor_version »: 1,
« domain »: « localtuya »,
« title »: « localtuya »,
« data »: {
« region »: « eu »,
« client_id »: «  »,
« client_secret »: «  »,
« user_id »: «  »,
« username »: « localtuya »,
« no_cloud »: true,
« devices »: {
« --------------------------------- »: {
« friendly_name »: « Climatiseur Salon »,
« host »: « 192.168.XXX.XXX »,
« device_id »: « ------------------------------- »,
« local_key »: « ------------------------ »,
« protocol_version »: « 3.3 »,
« enable_debug »: false,
« dps_strings »: [
« 1 (value: False) »,
« 2 (value: 160) »,
« 3 (value: 215) »,
« 4 (value: cold) »,
« 5 (value: high) »,
« 8 (value: False) »,
« 9 (value: False) »,
« 12 (value: False) »,
« 13 (value: True) »,
« 15 (value: off) »,
« 20 (value: 0) »,
« 22 (value: 0) »,
« 101 (value: 0) »,
« 102 (value: 0) »,
« 105 (value: c) »,
« 106 (value: off) »,
« 107 (value: off) »,
« 108 (value: False) »,
« 109 (value: False) »,
« 110 (value: True) »,
« 111 (value: False) »,
« 112 (value: cold) »,
« 113 (value: 0) »,
« 115 (value: False) »
],
« entities »: [
{
« id »: 1,
« friendly_name »: « Climatiseur Salon »,
« target_temperature_dp »: 2,
« current_temperature_dp »: 3,
« temperature_step »: 0.1,
« precision »: 0.1,
« hvac_mode_dp »: 4,
« hvac_mode_set »: « heat/cool »,
« temperature_unit »: « celsius »,
« target_precision »: 0.1,
« platform »: « climate »
}
{
« friendly_name »: « fan speed »,
« select_options »: « auto;low;low_mid;mid;mid_high;high;mute;turbo »,
« select_options_friendly »: « Auto;Bas;Moyen Bas;Moyen;Moyen haut;Haut;Silence;Turbo »,
« restore_on_reconnect »: false,
« is_passive_entity »: false,
« id »: 5,
« platform »: « select »
},
],
« product_key »: « keyquxnsj75xc8se »
}
},
« updated_at »: « 1714420483954 »
},
« options »: {},
« pref_disable_new_entities »: false,
« pref_disable_polling »: false,
« source »: « user »,
« unique_id »: «  »,
« disabled_by »: null
},

Bon 1er Mai à tout le monde.

Fabien

Ca ressemble à ça chez moi :
`

PS: Quand tu postes du code, tu dois le formatter avec le bouton </> sinon c’est illisible.

il manque une virgule entre les 2 } et {.

Sur le dernier bloc, { …}, il ne doit pas y avoir de virgule. Le json est strict et ne pardonne pas. Utilise toujours un éditeur JSON pour faire des modifs dans ce genre de fichiers. VSCode est parfait pour ça.

Hello,
Merci pour tout ces conseilles. C’est bien noté pour formatter le code dans les post. Je viens d’installer VScode en effet c’est quand même bien mieux que File Editor.
Bon peut importe ce que j’essais de faire je me retrouve toujours avec le fichier corrompu et mon HA inutilisable.
J’ai bien fait attention d’avoir la virgule après l’accolade fermante et ne pas avoir de virgule sur la dernière accolade du bloc.

Tu as des << à la place des ". C’est pas JSON.

Ah bas oui en effet ca fonctionne beaucoup mieux comme ca. Nan mais c’est laborieux :hot_face:
J’ai vraiment un gros travail à faire sur l’acquisition de compétence en Dev.
Bon je rajoute les autres entités et il me restera à les faire apparaitre sur mon Dashboard.
Un grand grand merci à toi.

1 « J'aime »

Dans ton VScode, tu as des plugins pour formatter et détecter le JSON. Tu devrais en installer un. Cherche json formatter dans les modules.

1 « J'aime »

Hello @Jean-Marc_Collin,
Je voulais te dire un énorme merci pour ton aide ta patience et ton accompagnement. Me voila avec le contrôle complet de ma PAC.
image
Et au passage tu m’as permis d’apprendre pleins de choses sur HA.

Grand merci à toi.

Fabien

1 « J'aime »

Un jour, je ferai peut être une intégration complète spécialement pour cette clim.

2 « J'aime »

Whaou alors ca, ca serait génial mais sans doute pas simple du tout. Et ca risque de demander énormément de temps. Ce qui est certains c’est que si d’autre sont intéressés ils ont tout le cheminement avec toutes les questions que j’ai pu te poser :joy:

1 « J'aime »

Whaou, je vais recevoir mes clim et vais essayer de les intégrer, j espère y arriver. Je croise les doigts… du côté du module wifi est ce quelqu’un en trouvé une ref compatible ??? Merci

bon va falloir que je lise comme il faut ce sujet, car je compte bien integrer ma clim du coup :slight_smile: