Qubino Fil Pilote et ZWaveJS

Un grand merci pour cette réponse rapide, je regarde tout cela dans l’après midi.
Merci :grinning:

Victoire !! un grand merci pour ta réponse mais ma sollution était ailleurs, je ne voyais pas comment définir mais entrées « climate » dans la « card » et malgrès le fait d’avoir lu et re-lu les infos sur GitHub, je ne voyais pas quoi faire des « Example ».
En fait il fallait que je les définissent dans mon fichier « configuration.yaml »

climate:

  • platform: qubino_wire_pilot
    heater: light.heater_living_room_dimmer
    additional_modes: true

Suite à cela, ma « card » thermostat est apparu correctement, le module « qubino wire pilot » servant à définir mes entités « light » comme des « climat » utilisable pour le thermostat. Le reste à couler de source…

Merci de t’être penché sur mon problème, même si cela ne la pas solutionné directement, cela m’a permis de l’envisager sous un autre angle et de trouver ma solution. :wink:

Me e « plus » qu’a coupler cela maintenant avec des plages de fonctionnement … :sweat_smile:

Bonjour,
est-ce que quelqu’un a réussi à faire fonctionner la sonde sur les ZMNHJD1 et faire en sorte qu’elle s’actualise automatiquement ?
Pour chaque module, j’ai procédé à deux exclusions de l’appareil puis à une inclusion avec la sonde branchée. Tout est bien détecté, le module et la sonde (la valeur x-40-0 Air temperature) est bonne. Néanmoins, cette valeur ne change pas, sauf si je clique sur le bouton « Refresh » de mon interface Zwave JS 2 MQTT. La variation de la température est supérieure à 5°C pendant mes tests.
J’ai documenté ce problème sur github : je ne peux pas mettre le lien, mais cherchez [bug] Qubino ZMNHJD1 flush pilot with ZMNHEA1 Sensor - no automatic refresh
J’ai contacté le supporte de Qubino : ils me renvoient vers « Planète Domotique »
J’ai contacté Planète Domotique : ils me disent que HASS n’est pas supporté…

1 « J'aime »

salut!
J’en suis au même point que toi, j’ai enfin réussi à créer mon entité « climate » et régler les modes depuis une carte dédiée.
Mon problème est que je n’arrive pas à créer plusieurs entités climate pour mes différents modules Qubino. Dans mon fichier configuration.yaml j’ai mis le code suivant, mais seulement la deuxième entitée est créée et accessible :

climate:
  - platform: qubino_wire_pilot
    heater: light.radiateurs_rdc
    unique_id: sensor.radiateurs_rdc
    name: Radiateurs RDC

climate:
  - platform: qubino_wire_pilot
    heater: light.radiateurs_chambres
    unique_id: sensor.radiateurs_chambres
    name: Radiateurs Chambres

Je pense que c’est tout bête mais pouvez-vous m’aider ?
Merci d’avance !

Juste comme ça, as-tu essayé de cette façon ?

climate:
  - platform: qubino_wire_pilot
    heater: light.radiateurs_rdc
    unique_id: sensor.radiateurs_rdc
    name: Radiateurs RDC
  - platform: qubino_wire_pilot
    heater: light.radiateurs_chambres
    unique_id: sensor.radiateurs_chambres
    name: Radiateurs Chambres

C’était effectivement très bête, j’ai encore de grosses lacunes avec la programmation sur HA :confused:
Merci de ta réponse rapide !

Salut à tous,

@heaven7, ça fait quelques jours, mais vu que tu n’as pas (encore) obtenu de réponse sur github, voici ma solution de contournement.

Pour ceux et celles à qui ça pourrait servir, il suffit de créer un petite automation :

- id: 'fetch_qubino_temperature'
  alias: "Rafraîchir la temprérature des Qubino ZMNHJD1"
  trigger:
    - platform: time_pattern
      minutes: '/5'
  action:
    - service: zwave_js.refresh_value
      data:
        entity_id: sensor.flush_pilot_air_temperature

Ou /5 est la récurrence (ici toutes les 5 minutes) et sensor.flush_pilot_air_temperature l’ID de la sonde de température dans Home Assistant.
Si vous avez plusieurs Qubino, ajoutez un bloc pour chacun après action: comme ceci

- id: 'fetch_qubino_temperature'
  alias: "Rafraîchir la temprérature des Qubino ZMNHJD1"
  trigger:
    - platform: time_pattern
      minutes: '/5'
  action:
    - service: zwave_js.refresh_value
      data:
        entity_id: sensor.flush_pilot_air_temperature
    - service: zwave_js.refresh_value
      data:
        entity_id: <sensor.id_de_ma_seconde_sonde>
    - etc
1 « J'aime »

Par contre, si on utilise le thermostat de HA (simple thermostat par exemple), cela condamne à utiliser le qubino fil pilote qu’en on/off si j’ai bien compris? Ne peut on pas utiliser le simple thermostat pour pilote tous presets du qubino et éviter ainsi les arrêts/relances du radiateur (sauter pour ma part) et prolonger sa durée de vie?

Tant mieux si ça fonctionne.
Après c’est une question de choix personnel mais j’imagine que tu mets ça pour avoir un suivi de la conso électrique. Moi j’ai quelques retissances.

  • Les fortes puissances (comme le chauffe eau) j’ai vécu une installation qui a cramé
  • Sur du matériel sensible comme la baie, trop peur que ça coupe / microcoupe sans raison…

Merci pour ton retour. C’est une partie de la solution ! Je viens de la mettre en place.
J’arrive à mettre à jour mes sensor, mais j’ai l’impression que les devices n’arrivent plus à remonter les valeurs quand on leur demande (avant chaque refresh manuel se mettait à jour, ce n’est plus le cas maintenant)…

Grâce à quelques échanges sur Github, j’ai trouvé une fonction dans Zwave JS 2 Mqtt
« Parameter »- « General » - « New Value ». Puis :
Selectionner le Device (ici Flush Pilot (Qubino), une valeur (49-0 Air Temperature), puis cocher Poll, 300 secondes.

Avec ça, pas besoin d’automation, c’est zwave JS qui gère tout.
Reste à confirmer pour moi que ça marche. J’en suis à tester différentes associations encore …
Edit : ça fonctionne très bien en gerant ça sur Zwave JS

Je pense avoir réussi à résoudre une partie de l’énigme sur les Qubino Fil Pilote ZMNHJD1. J’ai longtemps cru à des problèmes d’association (sur Zwave JS par défaut il n’y a que lifeline) mais je faisais fausse route.

Le problème que j’ai rencontré a pour cause une mauvaise inclusion. Pour l’inclusion voila les étapes que je faisais avant :

  1. je débranchais ma clé Zwave (Aeotec)
  2. J’active le bouton inclusion juste à côté du module installé et branche electriquement le module
  3. Je rebranche la clé Zwave sur le Pi. C’est à ce moment que Zwave JS fini l’interview du node (même si l’inclusion est déjà faite).

Je pense que cela ne pose pas de problème quand le module et le pi+clé Zwave sont proches, mais quand ils sont sur un autre étage cela en pose. De fait, l’interview semble terminée et se faire correctement, mais les valeurs de température des sondes ne fonctionne pas normalement (remontée aléatoire).

Hier, j’ai essayé les étapes suivantes :

  1. Branchement du module directement à côté du Pi et de la clé Zwave.
  2. Activation du mode inclusion directement dans Zwave JS (et je l’ai laissé faire le travail d’interview dans la foulée (qui s’est fait en quelques secondes, alors qu’avant ça prenait plusieurs minutes …).

Résultat : le module et sa sonde de température fonctionne enfin normalement (sauf le refresh automatique mais ça j’en parle dans mon précédent post).

Moral de l’histoire : toujours ajouter un module en le branchant à côté de la plateforme Zwave, puis l’installer après à sa place définitive
J’ai perdu beaucoup de temps à faire autrement … J’espère que cela aidera d’autres qui ont galéré comme moi.

Salut

Accessoirement ZwaveJS (et Z2M aussi d’ailleurs) propose une interface accessible à distance… Donc tu es tout à fait en mesure de prendre une tablette/pc/télephone et de déclencher la procédure d’association (sur la clé) depuis n’importe quel emplacement géographique (comprendre la place définitive du module)…
L’avantage non négligeable c’est de ne pas découvrir après l’association, les éventuelles soucis de réception

Evidemment d’un point de vue logiciel.
Sauf que faire une inclusion / interview alors que la plateforme et le module sont éloignés amènent justement aux problèmes que je décris (mauvais fonctionnement des sondes de température). Tout en respectant la procédure inclusion/exclusion de Qubino.
Ce n’est pas un problème de portée à l’utilisation (car j’ai d’autres modules à côté), mais à la première interview.
Mes conclusions sont peut-être sur-interprétées, mais c’est ce que je constate en tout cas.