Tydom de deltadore

Hello à tous, je reviens vers vous si vous pouvez m’aider

Suite à une coupure de courant hier, mon tydom qui fonctionnait bien pour mes volets ne veut plus rien savoir,

Ça me dit ça dans les logs :

2022-07-07 10:07:00,075 - tydomConnector - INFO - """"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
2022-07-07 10:07:00,076 - tydomConnector - INFO - TYDOM WEBSOCKET CONNECTION INITIALISING....                     
2022-07-07 10:07:00,077 - tydomConnector - INFO - Building headers, getting 1st handshake and authentication....
Traceback (most recent call last):
  File "/app/main.py", line 226, in <module>
    loop_task()
  File "/app/main.py", line 148, in loop_task
    loop.run_until_complete(listen_tydom_forever(tydom_client))
  File "/usr/local/lib/python3.10/asyncio/base_events.py", line 646, in run_until_complete
    return future.result()
  File "/app/main.py", line 160, in listen_tydom_forever
    await tydom_client.connect()
  File "/app/tydomConnector.py", line 108, in connect
    conn.request(
  File "/usr/local/lib/python3.10/http/client.py", line 1282, in request
    self._send_request(method, url, body, headers, encode_chunked)
  File "/usr/local/lib/python3.10/http/client.py", line 1328, in _send_request
    self.endheaders(body, encode_chunked=encode_chunked)
  File "/usr/local/lib/python3.10/http/client.py", line 1277, in endheaders
    self._send_output(message_body, encode_chunked=encode_chunked)
  File "/usr/local/lib/python3.10/http/client.py", line 1037, in _send_output
    self.send(msg)
  File "/usr/local/lib/python3.10/http/client.py", line 975, in send
    self.connect()
  File "/usr/local/lib/python3.10/http/client.py", line 1454, in connect
    self.sock = self._context.wrap_socket(self.sock,
  File "/usr/local/lib/python3.10/ssl.py", line 513, in wrap_socket
    return self.sslsocket_class._create(
  File "/usr/local/lib/python3.10/ssl.py", line 1071, in _create
    self.do_handshake()
  File "/usr/local/lib/python3.10/ssl.py", line 1342, in do_handshake
    self._sslobj.do_handshake()
ssl.SSLError: [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:997)

Est-ce que quelqu’un saurait ce que je dois faire ? :slight_smile:

Merci !

PS : j’ai désinstallé et réinstallé l’add-on, mais ça me fait la même chose. C’est comme si un truc dans le cache était foiré, mais je sais pas comment le nettoyer

EDIT : j’ai même désinstallé et réinstallé HA, j’ai remis une sauvegarde qui était bonne, et ça me fait la même chose :frowning:

Bonjour tout le monde,

J’ai installé le système Tydom2MQTT depuis quelques jours et depuis j’ai un problème avec ma box Tydom 2.0, qui se bloque et passe en voyant rouge, c’est à dire qu’elle n’a plus d’adresse IP.

Cela arrive seulement depuis que j’ai installé l’add-on…

J’ai essayé de la passer en IP fixe, en pressant le bouton T3 à l’intérieur de la box pendant 3 secondes mais elle reste en mode DHCP et ne passe pas en IP fixe.

Je reste bloqué ainsi et doit la redémarrer une à deux fois par jour pour que ça fonctionne.

Est-ce que quelqu’un a déjà eu ce problème ou à une solution possible pour mon problème.

Merci de votre aide !

Bonjour,
Je pense que ce message est passé inaperçu… Et c’est bien dommage !

Merci pour le travail, que le code soit propre ou non, ça à le mérite de fonctionner (Tydom Home).

Serait-il possible de réaliser une Pull Request pour que l’auteur du plugin le prenne en compte, stp ?

Merci !

Il y a une nouvelle version, je crois que fmartinou (l’auteur du plugin) a mergé avec ce que j’ai fait pour ajouter les fonctions de motion detector et door sensor.
Je vais essayer sa version ce weekend pour voir si ca me donne la même chose

Bonjour à tous, Le parametre TYDOM_ALARM_PIN n'apparait pas dans mon tydom2mqtt
et si je passe yaml et que je l'ajoute à la main j'ai une erreur, Une idee ?

Salut

Sans le yaml et sans l’erreur c’est pas facile de proposer une idée…


voila le yaml et l’erreur

En mode interface utilisateur pas de champ tydom alarm pin

TYDOM_ALARM_PIN est un string et doit donc être mis entre quotes. Par exemple :

TYDOM_ALARM_PIN: "1234"
1 « J'aime »

Merci, la sauvegarde marche mais ce paramètre n’apparait toujours pas en mode interface et le module tydom2mqtt ne démarre pas plus.

journal :
2022-10-10 19:14:23,429 - mqtt_client - INFO - MQTT host : localhost
2022-10-10 19:14:23,429 - mqtt_client - INFO - MQTT user :
2022-10-10 19:14:23,438 - mqtt_client - INFO - MQTT connection Error : Multiple exceptions: [Errno 111] Connect call failed (‹ 127.0.0.1 ›, 1883), [Errno 99] Address not available 2022-10-10 19:14:23,438 - mqtt_client - INFO - MQTT error, restarting in 8s…`

Pour cette intégration GitHub - max5962/tydom2mqtt: Link between a Delta Dore's Tydom Hub and and a MQTT broker, unofficial of course. ?

Si oui alors il y a plusieurs erreurs :

  • La structure YAML n’est pas conforme au modèle :
sensor: 
  - platform: Tydom2MQTT
    xxxxx
  • Aucun des noms ne respectent pas les majuscules/minuscules par exemple TYDOM_MAC versus tydomMAC
  • Des _ dans les noms qui ne sont pas valables
  • Des éléments inventés (MQTT_HOST, MQTT_SSL)

Pour cette intégration GitHub - max5962/tydom2mqtt: Link between a Delta Dore's Tydom Hub and and a MQTT broker, unofficial of course. ?
Si oui alors il y a plusieurs erreurs :

  • La structure YAML n’est pas conforme au modèle :
sensor: 
  - platform: Tydom2MQTT
    xxxxx
  • Aucun des noms ne respectent les majuscules/minuscules par exemple TYDOM_MAC versus tydomMAC
  • Les _ en trop
  • Des éléments qui ne semblent pas exister (MQTT_HOST, MQTT_SSL)

Je débute en home assistant. J’ai utilisé l’intégration de fmartinou tydom2mqtt .
dois-je modifier le fichier yaml manuellement ?

En version installée à partir de HACS ? Du coup, les noms sont meilleurs
Si oui, alors la configuration est à faire via l’UI
Selon la doc, seuls les points rouges sont obligatoires, les autres à renseigner si différents de la valeur par défaut

1 « J'aime »

merci pour cette info. j'avais fait une erreur avec le TYDOM_ALARM_PIN , j'avais mis 6 caractères il n'en faut que 4 !. J'ai des choses qui remontent. Merci encore

2 « J'aime »

Hello la team,
Est ce que l’un d’entre vous aurais des détecteur de fumé delta dore et aurais réussi à trouver le sensor associé aux niveau mqtt ?

Bonjour,

Je viens de découvrir ce thread et ayant une alarme Delta Dore avec la gateway Tydom 2.0, je me demandais si des personnes ayant la Tydom 2.0 utilisent cette integration, si oui, Pouvez-vous me dire si cela permet de suivre l’état de l’alarme (activée /désactivée) ou est-ce que cela permet aussi de l’activer/désactiver depuis HA et encore mieux via une automatisation gérée par Géolocalistation?

Merci d’avance pour vos réponses

Al