Tydom de deltadore

J’ai réussi à envoyer et compiler correctement l’image docker dans github.
Pour ceux que ça intéresse de tester d’avoir la remontée des détecteurs de mouvement et ouverture de porte (do bl). https://github.com/fransiouz/hassio-addons
En tout cas, ça marche dans ma config avec une Tydom 2.0 vidéo.

Bonjour à toute et à tous,

Je suis actuellement dans l’installation de l’addon tydom2mqtt, et je rencontre un problème.

Est-ce que quelqu’un aurait-il une idée?

Merci par avance.

Bonjour,
J’ai installé et configure Tydom 2 mqtt chez mon père ;
Cela fonctionne bien, et un grand merci au créateur ;
Est ce possible via une commande mqtt d’activer des zones d’alarme spécifiques (par exemple zone 1 et 3 lorsqu’on activé le mode nuit ? Actuellement on ne peut sélectionner qu’une seule zone …
J’ai cherché mais pas trouvé …
Avant j’utilisais jeedore sur jeedom et c’était possible, donc ça doit pouvoir se faire quelque part ? (Même si commande mqtt à part de l’interface de home assistant …) ?

Merci d’avance !

Bonjour,
Merci pour cette discussion qui va m’être utile, je vais d’ici 1 mois installer un Tydom 1.0 pour les contrôle de volets et chauffage.

As-tu paramétré TYDOM_ALARM_PIN sur la configuration de l’add-on tydom2mqtt ?

Même si on n’a pas d’alarme TYDOM, il faut paramétrer ce champ sinon tydom2mqtt plante en essayant de le parser. C’est un bug connu et pas encore corrigé.

1 « J'aime »

Merci ! Une heure que je tournais en rond à ne pas comprendre pourquoi cela ne marchait pas !

Bonjour à tous,
Je suis désolé d’avance, je vais faire un peu mon relou, mais je n’arrive pas à configurer l’addon malgré toutes mes recherches sur internet, et notamment ici.

J’ai installer Mosquitto broker (MQTT) sans rien vraiment configurer dessus.
J’ai installé l’addon tydom2mqtt en essayant de remplir les informations dans la partie « Configuration »,
J’ai bien mis :

  • L’adresse Mac du tydom
  • L’adresse IP du tydom
  • Mon mot de passe Tydom (mais j’suis pas sûr, j’ai cru comprendre que c’était un code d’accès au boitier ?)
  • J’ai rien touché aux zone maison etc
  • Adresse du serveur MQT j’ai laissé par défaut homeassistant
  • Pour identifiant et mot de passe y’a homeassistant et rien (en mdp)
  • et 1883 pour le port

Bien entendu, ça ne fonctionne pas, dans le journal de laddon j’ai :

2022-06-25 19:42:12,847 - mqtt_client - INFO - """"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
2022-06-25 19:42:12,847 - mqtt_client - INFO - Attempting MQTT connection...
2022-06-25 19:42:12,848 - mqtt_client - INFO - MQTT host : localhost
2022-06-25 19:42:12,849 - mqtt_client - INFO - MQTT user : 
2022-06-25 19:42:12,858 - mqtt_client - INFO - MQTT connection Error : Multiple exceptions: [Errno 111] Connect call failed ('xxx.x.x.x', 1883), [Errno 99] Address not available
2022-06-25 19:42:12,858 - mqtt_client - INFO - MQTT error, restarting in 8s...

Où est-ce que je m’y prends mal ? :frowning:
Merci de votre aide !

@JeanJean As-tu ajouté l’intégration Mosquitto Broker avec un nouvel utilisateur créé sur ton HA ?

Merci de ton retour !

J’ai bien l’intégration Mosquitto broker mais sans utilisateur créé pour lui, vu qu’il m’indique que ce n’était pas forcément nécessaire.

Je dois créer un profil spécialement pour lui ? Admin ?

Oui c’est mieux de créer un nouvel utilisateur (par ex: « mqtt », avec un mot de passe bien long), et le configurer dans l’intégration Mosquitto Broker (configure > reconfigure).

Merci encore,

Je viens de le faire, sans succès.
J’ai :

  • créer un nouveau user mqtt-user avec un mdp
  • été dans MQTT dans mes appareils, fait « reconfigure » et mis les identifiants,
  • reconfiguré les infos dans l’addon tydom

Mais j’ai toujours le même message d’erreur…

Avez-vous un tuto complet sur comment installer le tout quelque part ? :slight_smile:

Je n’ai pas de tuto complet malheureusement, j’avais galéré à trouver toutes les infos aussi. Il faudrait que j’en écrive un si je trouve le temps…

Est-ce que tu peux poster (en censurant les mdp), les confs de :

  • Ton addon « Mosquitto broker »
  • Ton integration « Mosquitto broker » (les deux écrans)
  • Ton addon tydom2mqtt

As-tu essayé de publier un message et d’écouter le même topic via la page de configuration de l’integration « Mosquitto broker » ?

Hello,

Oui j’ai bien les sujets que j’écoute (capture ci dessous)

J’ai refait toute la configuration de MQTT et son addon, et (surtout) j’ai rajouté un pin (9999) à l’alarme, même si j’en ai pas, dans tydom.

Ça a fait avancer un peu le truc, mais j’ai un nouveau message d’erreur :

2022-06-27 13:37:50,737 - __main__ - INFO - ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2022-06-27 13:37:50,737 - __main__ - INFO - ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2022-06-27 13:37:50,738 - __main__ - INFO - ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2022-06-27 13:37:50,738 - __main__ - INFO - STARTING TYDOM2MQTT
2022-06-27 13:37:50,739 - __main__ - INFO - Detecting environnement......
2022-06-27 13:37:50,739 - __main__ - INFO - /data/options.json detected ! Hassio Addons Environnement : parsing options.json....
2022-06-27 13:37:50,740 - tydomConnector - INFO - Initialising TydomClient Class
2022-06-27 13:37:50,741 - tydomConnector - INFO - Setting local mode context.
2022-06-27 13:37:50,749 - __main__ - INFO - Starting main loop_task
/app/main.py:141: DeprecationWarning: There is no current event loop
  loop = asyncio.get_event_loop()
2022-06-27 13:37:50,753 - mqtt_client - INFO - """"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
2022-06-27 13:37:50,753 - mqtt_client - INFO - Attempting MQTT connection...
2022-06-27 13:37:50,754 - mqtt_client - INFO - MQTT host : homeassistant
2022-06-27 13:37:50,755 - mqtt_client - INFO - MQTT user : Tydom
2022-06-27 13:37:50,781 - gmqtt.mqtt.protocol - INFO - [CONNECTION MADE]
2022-06-27 13:37:50,786 - mqtt_client - INFO - ##################################
2022-06-27 13:37:50,786 - mqtt_client - INFO - Subscribing to : +/tydom/#
2022-06-27 13:37:50,787 - gmqtt.mqtt.package - INFO - [SEND SUB] 1 [b'homeassistant/status']
2022-06-27 13:37:50,789 - gmqtt.mqtt.package - INFO - [SEND SUB] 2 [b'+/tydom/#']
2022-06-27 13:37:50,792 - tydomConnector - INFO - """"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
2022-06-27 13:37:50,793 - tydomConnector - INFO - TYDOM WEBSOCKET CONNECTION INITIALISING....                     
2022-06-27 13:37:50,794 - tydomConnector - INFO - Building headers, getting 1st handshake and authentication....
2022-06-27 13:37:51,939 - tydomConnector - INFO - Upgrading http connection to websocket....
2022-06-27 13:37:51,940 - tydomConnector - INFO - Attempting websocket connection with tydom hub.......................
2022-06-27 13:37:51,940 - tydomConnector - INFO - Host Target : 192.168.1.85
2022-06-27 13:37:52,075 - gmqtt.mqtt.handler - INFO - [SUBACK] 1 (0,)
2022-06-27 13:37:52,076 - gmqtt.mqtt.handler - INFO - [SUBACK] 2 (0,)
2022-06-27 13:37:53,241 - tydomConnector - ERROR - Exception when trying to connect with websocket !
2022-06-27 13:37:53,242 - tydomConnector - ERROR - server rejected WebSocket connection: HTTP 401
2022-06-27 13:37:53,243 - tydomConnector - ERROR - wss://192.168.1.85:443/mediation/client?mac=001A250XXXX&appli=1
2022-06-27 13:37:53,243 - tydomConnector - ERROR - {'Authorization': 'Digest username="001A250XXXX", realm="protected area", nonce="fda702axxxxxxxxxx88c8d", uri="/mediation/client?mac=001A250XXXX&appli=1", response="6f324xxxxxxxxxxxxxd37f7", qop="auth", nc=00000001, cnonce="4b31325d84ca717c"'}

(j’ai rajouté des xxxx pour les trucs qui me semblaient sensibles mais peut être pas)

Erreur d’authentification. Assure toi d’avoir bien saisi le mdp de la box Tydom, et pas le mot de passe de ton compte Tydom.

Ah !
C’est moi qui ai créé ce code ?

Sinon je viens de voir c’est une procédure d’ancienne version de lapp etc right ?

Oui c’est ça, la nouvelle version de l’application Tydom ne permet pas de reset ce mot de passe, il faut installer une ancienne version.

J’essaie ce soir ! Merci beaucoup

Super tout fonctionne merci encore !!
J’ai pas mis un super « code pin » pour le tydom (mais sur mon compte tydom le MDP est fort), c’est grave ?

:+1:

Comme tous les mots de passe, plus c’est long et mieux c’est. :wink:

Hello à tous

J’ai fait la mise à jour de tydom2mqtt aujourd’hui et de nouveau le message d’erreur ahah

Je vais voir à quoi ça peut être dû …

Edit : j’ai trouvé à quoi c’était dû, il faut changer le mdp de tydom par celui de son compte (plutôt que celui de son boitier)