Piloter sa pompe à chaleur MITSUBISHI en local avec une sonde déportée

Bonjour,

Chose promise, chose due.
Un petit tuto sur le fait de piloter sa pompe à chaleur MITSUBISHI en local avec une sonde déportée.
J’avais essayé avec une carte ESP8266, un clone de la WEMOS MINI D1. La carte que j’ai reçue ne dialogue pas avec l’unité, du coup je me suis rabattu sur ce qui est préconisé dans le git officiel de SwiCago, à savoir une carte ESP-01.
Les clones des cartes WEMOS MINI D1 posent problèmes. Voir ICI, d’où mon choix.

Ma clim est une MSZ-AP50VG(K) et la sonde de température déportée est une Sonoff ZigBee SNZB-02.

I/ Les pré-requis :

II/ Préparer le module ESP-01 pour sa programmation:

D’autres possibilités existent pour programmer le module ESP-01. Je vous en présente deux que j’ai utilisé et qui fonctionnent parfaitement.

  • Adaptateur USB pour ESP8266 ESP-01 :
    Pour programmer l’ESP-01 il faut le passer en mode programmation en reliant les PIN Ground et IO0. Mettre un fil sur l’adaptateur USB comme sur l’image.
    image
    Puis connecter l’ESP-01 sur l’adaptateur USB.
    image

  • FTDI USB/UART 3.3V 5.5V :
    image

III/ Programmer le module ESP-01:

Basé sur le tuto suivant : Installer ESPHome sur Home Assistant et créer votre première configuration

substitutions:
  name: clim-esphome-mitsubishiheatpump
  friendly_name: Ma Clim Mitsubishi Heat Pump


esphome:
  name: ${name}
  platform: ESP8266
  board: esp01_1m
  # Boards tested: ESP-01S (ESP8266), Wemos D1 Mini (ESP8266); ESP32 Wifi-DevKit2

wifi:
  # Éditer le ssid et le password dans la page principale de ESPHome
  ssid: !secret wifi_ssid
  password: !secret wifi_password
  power_save_mode: none
  
  # Vous pouvez choisir une IP Fixe. Changer les valeurs static_ip et gateway par l’IP choisie et celle de la box internet
  #manual_ip:
    #static_ip: 192.168.1.100
    #gateway: 192.168.1.254
    #subnet: 255.255.255.0

  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "${friendly_name} Fallback Hotspot"
    password: "1234"

# Note: if upgrading from 1.x releases of esphome-mitsubishiheatpump, be sure
# to remove any old entries from the `libraries` and `includes` section.
#libraries:
  # Remove reference to SwiCago/HeatPump

#includes:
  # Remove reference to src/esphome-mitsubishiheatpump

captive_portal:

# Enable logging
logger:
  # ESP8266 only - disable serial port logging, as the HeatPump component
  # needs the sole hardware UART on the ESP8266
  baud_rate: 0

# Enable Home Assistant API
api:

ota:
  password: "51ab42c48eeb3b3b54ca934ad0051347"

# Enable Web server.
web_server:
  port: 80

  # Sync time with Home Assistant.
time:
  - platform: homeassistant
    id: homeassistant_time

# Text sensors with general information.
text_sensor:
  # Expose ESPHome version as sensor.
  - platform: version
    name: ${name} ESPHome Version
  # Expose WiFi information as sensors.
  - platform: wifi_info
    ip_address:
      name: ${name} IP
    ssid:
      name: ${name} SSID
    bssid:
      name: ${name} BSSID

# Sensors with general information.
sensor:
  # Uptime sensor.
  - platform: uptime
    name: ${name} Uptime

  # WiFi Signal sensor.
  - platform: wifi_signal
    name: ${name} WiFi Signal
    update_interval: 60s
    
  # Vous pouvez choisir une sonde extérieure depuis Home Assistant.
  # Remplacer la valeur entity_id par votre sensor de température.
  #- platform: homeassistant
    #name: "Temperature Sensor From Home Assistant"
    #entity_id: sensor.salon_temperature
    #on_value:
      #then:
        #- lambda: 'id(hp).set_remote_temperature(x);'

external_components:
  - source: github://geoffdavis/esphome-mitsubishiheatpump

climate:
  - platform: mitsubishi_heatpump
    name: "${friendly_name}"
    id: hp

    # ESP32 only - change UART0 to UART1 or UART2 and remove the
    # logging:baud_rate above to allow the built-in UART0 to function for
    # logging.
    hardware_uart: UART0

IV/ Connecter le module ESP-01 au Climatiseur Mitsubishi:

Connectez l’ESP-01 à l’unité intérieure sur le connecteur CN105 de couleur rouge, en respectant le schéma suivant :

V/ Le résultat :

A vous de jouer !!! :wink:

2 « J'aime »

Excellent! Merci pour le partage. Ca mériterait même un sujet dédié en tant que tuto ou projet diy!
J’ai exactement la même clim!

2 « J'aime »

C’est un message que je voulais faire à l’article qui parle du smart thermostat: un intégrateur est dangereux lorsque le système à commander est très lent.
En effet, lors d’un changement de consigne, on se retrouve vite en saturation des radiateurs et comme nous ne sommes pas à la consigne, l’intégrateur continue à grimper (ou diminuer)… Il faut donc bloquer les intégrateurs lorsque les radiateurs sont au max ou à zéro, sinon une fois la température atteinte, ils restent saturés et on dépasse largement la consigne.
Je suis en train de réfléchir (lentement) à une autre façon de procéder qui estime les pertes quelque soit la commande du radiateur et qui les compense. Ce genre d’estimateur ferait un très bon complément au thermostat de @Argonaute :
https://forum.hacf.fr/t/gestion-de-bout-en-bout-du-chauffage/4897

1 « J'aime »

Si un modo veut et peut s’en charger, on pourrait effectivement continuer à échanger spécialement pour les PAC mitsubishi. :blush:

C’est fait :wink:
Bon chauffage

1 « J'aime »

Un grand merci @Pulpy-Luke :grin::grin::grin:

1 « J'aime »

Au sujet des intégrateurs du PID, j’ai fais des simulations avec ou sans blocage de l’intégrateur lorsque le radiateur est en limite de fonctionnement (max ou sur off):

Dans le dessin ci dessus, c’est une montée en température de 10° à 20° avec un besoin de 1500W pour compenser la température extérieure. Je compare des régulateurs proportionnel-intégral:

  • PI seul
  • PI+compensation de température externe
  • PI seul + blocage de l’intégrale
  • PI+compensation + blocage de l’intégrale

Le temps est en heures.
L’idéal est de limiter l’intégrateur à ce que les radiateurs savent faire (pas montré ici) et de le bloquer lorsque le radiateur est en limite.

Salut à tous,

De base, j’ai commencé HA pour faire remonter les infos de l’eau de ma piscine :slight_smile: via un ESP32 en MQTT.
J’ai quelques outils et consommables à dispo : du fil 24 AWG et des connecteur JST et là j’ai un doute.

Des prises (PAP-05V-S) et leurs connecteurs (SPHD-002T-P0.5)

Les miens (ci dessous en Photos) n’iront pas sur le connecteur CN105 ?


@thecrazylegs
Bonjour,
A mon avis ils ne sont pas compatibles… :thinking: Où alors il faut bidouiller.


Merci pour le retour je m’en doutais un peu :wink: reste plus qu’à trouver tout sans en avoir 300 pièces MDR

Une adresse ou site pour les commander, sur Amazon ça me semble abusé le tarif

@thecrazylegs
Pour la prise : Amazon.
Pour les connecteurs femelles : Conrad.

1 « J'aime »

ils se sont gourré dans la photo du produit mais c’est la bonne ref et moins cher qu’Amazon

Bon ok 9€ de FDP

Top !!!
Conrad n’en avait pas lorsque j’ai commandé les miens. Les frais de livraison sont plus cher que les produits commandés. Mais ça vaut le coup pour l’usage qui suit derrière. :wink:

Les PAP sont super petits, c’est pas les largeurs de connecteurs habituels sur les ESP & co.

Les seuls que j’ai trouvé tout fait c’est ça sur Ali.
Seul souci, les câbles font 10cm…

@AlexHass
Tu les as commandé ?

Oui, réceptionné depuis longtemps.
Tout est prêt, juste à brancher… mais ma clim est à plus de 4m de haut… pas encore eu le temps d’emprunter une échelle assez haute :slight_smile:

@AlexHass
Tu fais durer le plaisir :sweat_smile: :joy:

Ouais clair :slight_smile:
Mais bon c’est l’hiver elle est en hibernation la clim, ça presse pas…!
:cold_face:

Salut,

Je ne suis pas du tout habitué à ESPHOME flashé etc etc.
J’ai mon arduino IDE où j’ai déjà fait un montage avec un ESP32 bien bien sympa pour ma piscine pour que ça me renvoi sur HA / Mosquitto la data de mon eau.

Là c’est bien plus simple :slight_smile: et je suis perdu.
J’ai réussi à Flasher l’ESP01 aucun soucis, mais dans HA > ESPHOME mon Entity se fou en Offline au bout de 3s. et je n’arrive pas mettre à jour l’ESP avec le code pour le PAC Mitshubi…

J’ai ouvert mon IDE Arduino, ajouté les cartes ESP8266 sélectionné mon port et j’ai ouvert le Serial Minotor en espérant avoir une sortie pour au moins voir si la connexion wifi était OK ou pas un truc comme et bingo :

C’est le meilleur baud que j’ai trouvé pour que ce soit lisible LoL

[0;36m[D][wifi:388]: Found networks:[0m
[0;32m[I][wifi:431]: - '[[monssid]] 2.4' [5m(BB:BB:BB:BB:BB) [6m[0;33m▂���[0;37m▆█[0m[0m
[0;36m[D][wifi:433]:     Channel: 9[0m
[0;36m[D][wifi:434]:     RSSI: -74 dB[0m
[0;36m[D][wifi:436]: - [5m'*********'[6m [5m(AA:AA:AA:AA) [6m[0;33m▂▄[0;37m��█[0m[0m
[0;32m[I][wifi:248]: WiFi Connecting to '[[monssid]] 2.4'...[0m
[0;32m[I][wifi:505]: WiFi Connected![0m
[0;35m[C][wifi:353]:   Local MAC: 30:83:98:B2:F3:A4[0m
[0;35m[C][wifi:354]:   SSID: [5m'[[monssid]] 2.4'[6m[0m
[0;35m[C][wifi:355]:   IP Address: 192.168.2.xxx[0m
[0;35m[C][wifi:356]:   BSSID: [5mBB:BB:BB:BB:BB[6m[0m
[0;35m[C][wifi:358]:   Hostname: 'acbureau'[0m
[0;35m[C][wifi:360]:   Signal strength: -77 dB [0;33m▂��[0;37m▆█[0m[0m
[0;35m[C][wifi:364]:   Channel: 9[0m
[0;35m[C][wifi:365]:   Subnet: 255.255.255.0[0m
[0;35m[C][wifi:366]:   Gateway: 192.168.2.1[0m
[0;35m[C][wifi:367]:   DNS1: 192.168.2.1[0m
[0;35m[C][wifi:368]:   DNS2: 0.0.0.0[0m
[0;36m[D][wifi:514]: Disabling AP...[0m
[0;35m[C][ota:085]: Over-The-Air Updates:[0m
[0;35m[C][ota:086]:   Address: acbureau.local:8266[0m
[0;35m[C][ota:089]:   Using Password.[0m
[0;33m[W][ota:094]: Last Boot was an unhandled reset, will proceed to safe mode in 4 restarts[0m
[0;35m[C][api:025]: Setting up Home Assistant API server...[0m
[0;32m[I][app:062]: setup() finished successfully![0m
[0;32m[I][app:102]: ESPHome version 2022.2.5 compiled on Feb 28 2022, 21:33:15[0m
[0;35m[C][wifi:491]: WiFi:[0m
[0;35m[C][wifi:353]:   Local MAC: 30:83:98:B2:F3:A4[0m
[0;35m[C][wifi:354]:   SSID: [5m'[[monssid]] 2.4'[6m[0m
[0;35m[C][wifi:355]:   IP Address: 192.168.2.xxx[0m
[0;35m[C][wifi:356]:   BSSID: [5mBB:BB:BB:BB:BB[6m[0m
[0;35m[C][wifi:358]:   Hostname: 'acbureau'[0m
[0;35m[C][wifi:360]:   Signal strength: -78 dB [0;33m��▄[0;37m▆���[0m[0m
[0;35m[C][wifi:364]:   Channel: 9[0m
[0;35m[C][wifi:365]:   Subnet: 255.255.255.0[0m
[0;35m[C][wifi:366]:   Gateway: 192.168.2.1[0m
[0;35m[C][wifi:367]:   DNS1: 192.168.2.1[0m
[0;35m[C][wifi:368]:   DNS2: 0.0.0.0[0m
[0;35m[C][logger:233]: Logger:[0m
[0;35m[C][logger:234]:   Level: DEBUG[0m
[0;35m[C][logger:235]:   Log Baud Rate: 115200[0m
[0;35m[C][logger:236]:   Hardware UART: UART0[0m
[0;35m[C][captive_portal:144]: Captive Portal:[0m
[0;35m[C][mdns:084]: mDNS:[0m
[0;35m[C][mdns:085]:   Hostname: acbureau[0m
[0;35m[C][ota:085]: Over-The-Air Updates:[0m
[0;35m[C][ota:086]:   Address: acbureau.local:8266[0m
[0;35m[C][ota:089]:   Using Password.[0m
[0;33m[W][ota:094]: Last Boot was an unhandled reset, will proceed to safe mode in 4 restarts[0m
[0;35m[C][api:138]: API Server:[0m
[0;35m[C][api:139]:   Address: acbureau.local:6053[0m
[0;35m[C][api:143]:   Using noise encryption: NO[0m
[0;36m[D][api:102]: Accepted 192.168.2.[IP ESP][0m
[0;36m[D][api.connection:826]: Home Assistant 2022.2.9 (192.168.2.[IP ESP]): Connected successfully[0m
[0;32m[I][ota:105]: Boot seems successful, resetting boot loop counter.[0m

ça semble ok, non ?

Quand souhaites verser le code de la seconde étape :

INFO Reading configuration /config/esphome/acbureau.yaml...
INFO Detected timezone 'Europe/Paris'
INFO Generating C++ source...
INFO Compiling app...
Processing acbureau (board: esp01_1m; framework: arduino; platform: platformio/espressif8266 @ 3.2.0)
--------------------------------------------------------------------------------
HARDWARE: ESP8266 80MHz, 80KB RAM, 1MB Flash
LDF: Library Dependency Finder -> https://bit.ly/configure-pio-ldf
Dependency Graph
|-- <ESPAsyncTCP-esphome> 1.2.3
|-- <ESPAsyncWebServer-esphome> 2.1.0
|   |-- <ESPAsyncTCP-esphome> 1.2.3
|   |-- <Hash> 1.0
|   |-- <ESP8266WiFi> 1.0
|-- <DNSServer> 1.1.1
|-- <ESP8266WiFi> 1.0
|-- <ESP8266mDNS> 1.2
|-- <ArduinoJson> 6.18.5
|-- <HeatPump> 1.0.0+sha.70ec88f
RAM:   [====      ]  41.9% (used 34296 bytes from 81920 bytes)
Flash: [=====     ]  45.1% (used 461409 bytes from 1023984 bytes)
========================= [SUCCESS] Took 6.64 seconds =========================
INFO Successfully compiled program.
INFO Resolving IP address of acbureau.local
INFO  -> 192.168.2.[IP ESP]
INFO Uploading /data/acbureau/.pioenvs/acbureau/firmware.bin (465568 bytes)
INFO Compressed to 319389 bytes
ERROR Error auth result: Error: Authentication invalid. Is the password correct?

ça vous parle ? pourquoi il coinne sur le password ? lequel pas le wifi sans doute celui de l’AP acbureau ou l’OTA ?

Thks

Salut,

ça ressemble plutôt à un souci de config ESPHome au niveau des mots de passe OTA que tu avais au moment de compiler la version est chargée sur ton ESP et celui que tu as maintenant, est-il possible que tu ait changé quelque chose? ou recréé un nouveau « device » dans ESPHome?

Normalement ESPHome c’est plutôt simple à utiliser une fois qu’on a chargé la première version sur l’esp, les mises à jour OTA c’est super rapide.

Ca vient de ça je pense dans ton log:

`[0;33m[W][ota:094]: Last Boot was an unhandled reset, will proceed to safe mode in 4 restarts`

Dans mes devices j’ai les autres lignes OTA, mais pas celle-là…
Faut regarder sur ESPHome.io ce que ça veut dire safe mode…

2 « J'aime »